Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface → Themes
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by hhannah - 2010-11-11
Last edited by Buschel - 2011-07-27

FS#11749 - AA not recognized after changing theme

At least since 3.7 and after that to date

When changing themes, album art won't be recognized after the new theme is selected, the theme will behave as if there's no album art for the current track, and on. Rockbox has to be restarted in order to behave normally again with the selected theme.

When the new theme is selected and not displaying AA, if the previous theme is loaded again, AA displaying works fine.

If the sbs displays album art, it seems to work fine all the time, even if the wps won't display it due to the problem described.

This problem only seems to happen when the theme loads an sbs, but that'd have to be verified.

It also seems that when the new selected theme uses the same AA size, the problem doesn't occur.

A few times, I've been able to change the themes with different AA sizes, without this problem occurring, but I have not identified a pattern.

Closed by  Buschel
2011-07-27 18:27
Reason for closing:  Works For Me
Additional comments about closing:  

Tested with r30203.

Does the Album art flash briefly on the screen and disappear? If so my e200 only exhibits this behavior when using the art WPS. and restarting rockbox does not fix it for me.

No, the AA doesn't flash, it's just as if the album art would not be recognized, the themes adopt the no album art conditionals. Judging by the other details you describe, I'd say it's a different issue.

Would you upload one of your cover.jpgs and let me compare it to one of mine?

I've noticed this problem too, and I can confirm everything that Humberto says about switching themes having AA images with the same or differing sizes. I'm running a 3.8 version (r29534) on ipod nano, and I'm not using embedded AA. Also, restarting rockbock solves the problem for me if a loaded theme is not displaying AA. I can't confirm or deny what is mentioned about the sbs files.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing