Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System iriver H10
  • Severity Low
  • Priority Very Low
  • Reported Version Release 3.6
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by menachem - 2010-11-18
Last edited by Buschel - 2011-03-09

FS#11764 - Fastforwarding, Rewinding, or Selecting a different file to play may cause freezing or static

Summary:

I have an iRiver 20GB H10 running Rockbox 3.7. I recently updated from 3.4 (or 3.5 – i’m not entirely sure) and have started noticing the following problems.

When I’m listening to audio files on my mp3, I’ll often fast forward or rewind a little bit, depending on what I’m listening to. Sometimes while a file is playing, I will browse my files and select another one to play.

Most of the time this works as expected but sometimes (maybe %10-15 of the time) playback will get corrupted, and the only solution is to reboot the player. Most commonly, the file looks like it loads but sound stops working. Trying to get it working again by loading another file (using a bookmark or just clicking on the file) or reloading the file doesn’t work. Instead the player freezes up and the only solution is to restart the player. However, powering down takes a lot longer than usual, and I have to hold down the power key the whole time. Then it seems like the player doesn’t go off until I let go the power key I had been holding. Most of the time, rebooting the player works and the file continues playing.

Less commonly, when I try to load a new file instead of playing all I get it a bunch of static, which continues until I reboot the player.

I have attached a resent settings dump of my player.

Closed by  Buschel
2011-03-09 19:29
Reason for closing:  Fixed
Additional comments about closing:  

This is assumed fixed with r29476. The change has been merged to v3.8 branch as well and might be part of a 3.8.x version.

Since this apparently used to work, your best bet is to narrow it down to which revision broke skipping for you. Otherwise its going to be nearly impossible to trouble shoot this.

This may be the same issue as the one described here: http://www.rockbox.org/tracker/task/11775

p.h. commented on 2010-12-13 09:31

The bug was introduced by a firmware/drivers/button.c changes introduced in rev. 28143-28144 as rev. 28142 works fine and 28144 has the bug.

How do I download rev. 28142?

p.h. commented on 2010-12-14 22:35

From SVN only (sources). It means you would have to build it by yourself.
It will be easier if you downgrade to 3.6.

I’ve been running r29178-110131 for a while now, and haven’t seen the freezing behavior since I updated. I’ll let you know if i see it again.

I have been using 3.8RC since it came out, and just had the problem where, after about 5 seconds after the mp3 started playing, the player stopped playing and started making static instead. (I can’t remember now if this happened when resuming from a bookmark or after rewinding the mp3, but I think it was after resuming a bookmark)

I had to shut off the player and restart it to get it to work again.

This is the first (and so far only) time this has happened so far, so it is definitely happening less often than it did with 3.7.1. However, I never had an issue with r29178-110131.

You may want to try the current build - r29387 in the trunk (but not in 3.8) might have fixed this.

I was hoping it would get fixed for 3.8, but looks like that window has closed.

We like to put major changes in after a release (not before), so there’s plenty of time to test them. Please could you try a current build and report back?

OK. I just installed the latest build r29466. I will let you know if the problem starts occurring again.

menachem - was it fixed for you in that build?
if not, r29476 has additional fixes that might make the problem go away for you.

p.h. commented on 2011-03-03 22:20

I have tested rev. 29487 and I may tell the issue has been fixed.

However I am not convinced that it was thanks to switching off DMA in rev. 29476. As I have written above the bug was introduced by changes in firmware/drivers/button.c from rev. 28143-28144. You can use rev. 29475 (to have DMA ON) and revert the button.c to the rev. 28142 to see by yourself that the problem will not occur.

Dave - I haven’t had the issue since I updated to r29476, but it’s only been a couple days.

I’ll let you know if anything changes.

I’ll stay with this build for a while. If a failure occurs that may help narrow down the issue.

Dave - I haven’t had the issue since I updated to r29476, but it’s only been a couple days.

I’ll let you know if anything changes.

I’ll stay with this build for a while. If a failure occurs that may help narrow down the issue.

p.h. commented on 2011-03-04 22:28

The issue has been fixed in an earlier revision than 29476. I have tested 29475 and it worked fine. As I have tested the issue was introduced in rev. 28143 (28142 is the last one which worked fine).

To quickly find out whether the issue is present you can open a long MP3 file (I use 2h00m recording) and immediately fast forward near the end of it, for example to 1h45m. Then rewind it near the beginning and once again near the end. Then rewind it some 15m. At some point it won’t start to play but freeze.

Revision 28143 always freezes and usually after first fast forwarding.

Since December I have used subsequent revisions with firmware/drivers/button.c from rev. 28142 and I had no problem. My builds were used used by one more person who reported the issue before and for him my builds with button.c from rev. 28142 worked flawlessly too.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing