FS#11788 - Keyboard dissapears when you press up arrow immediately after seeing the keyboard

Attached to Project: Rockbox
Opened by Christian Blackburn (seier) - Wednesday, 01 December 2010, 07:26 GMT
Last edited by Alex Parker (BigBambi) - Wednesday, 01 December 2010, 09:14 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Release 3.7.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


The keyboard disappears immediately if you're first action when seeing the keyboard is to press the up arrow.

(From FM Radio in Preset Mode)
1. Press Home
2. Hold down select key
3. Press Select once to edit preset
4. Press Up Arrow
This task depends upon

Closed by  Alex Parker (BigBambi)
Wednesday, 01 December 2010, 09:14 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  This isn't a bug, it si by design. See the manual for the key assignments. If you think they should be changed, then please bring it up on the dev mailing list, or submit a patch.
Comment by Christian Blackburn (seier) - Wednesday, 01 December 2010, 07:27 GMT
I should also note I was using a Sansa Fuze v2, that may or may not be relevant.
Comment by Michael Stummvoll (Stummi) - Wednesday, 01 December 2010, 08:08 GMT
This is not a bug. With the up-key you are accepting your input. If you leave this empty, the preset will not get renamed. If you want to navigate through the keyboard you have to use the scrollwheel.

If you want to improve the keyboard control, you are free to submit a patch.