Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category FM Tuner
  • Assigned To No-one
  • Operating System Another
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Kyle - 2010-12-19
Last edited by bertrik - 2011-06-02

FS#11813 - Frequency is not tuned the first time the radio is turned on

The first time the FM radio is turned on on my Sansa Clip+, either from the menu or when it is selected as the start or wakeup screen, no frequency is tuned, resulting in hissing FM static. Once the radio sound is turned off, either by muting the sound using the “up” button, switching to music or mic recording or returning to the main menu by holding the “up” button, or if a frequency is tuned manually or from the preset list, the radio automatically tunes the last heard frequency every time the radio is turned back on in future, until the player is turned off, or in the case of manual tuning, the radio tunes correctly and then tunes the last heard frequency once it is turned off and then back on. It seems the select key can also be pressed twice to force tuning of the last heard frequency if it has been set from the preset list. This makes using the radio as a wakeup alarm impossible, because it always produces an FM hiss no matter what frequency was tuned when the player was turned off. If possible, the last frequency should be tuned immediately upon entering the radio the first time after the player is turned on. It would seem that this tuning may need to be forced in this case.

Closed by  bertrik
2011-06-02 15:19
Reason for closing:  Fixed
Additional comments about closing:  

Should be fixed with SVN r29946

Perhaps if you set a preset to your favorite station and delete the other presets, you could work around the issue you’re having, maybe not though.

Confirmed, still the same with Sansa Clip+ and Rockbox 3.8.1.

@Benjamin: Nope, doesn’t work.

I confirm that the bug is still present in the current build r29869-110513. First time I noticed the bug at the beginning of the year.

The original description is inaccurate. The first time the FM radio is turned on, unknown frequency is tuned. I hear badly tuned station playing. I identified the station and it seems that at my location the station is receivable only at 98.1 MHz. So I think that after turning on my Sansa Clip+ always tune to a frequency close to 98 MHz.

Does this problem depend on the type of tuner used (RDA5802 or SI4700)? You can figure out the tuner type by going to menu System / Debug / FM Radio.

I observe the problem with RDA5802.

The problem seems to be that the initialisation sequence writes values that cause it to tune to a specific frequency, interfering with the tune done by rockbox.
I found a fix and will commit it soon.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing