Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Battery/Charging
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Release 3.7.1
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by some-xtc - 2010-12-23
Last edited by kugel. - 2011-06-05

FS#11826 - M:Robe 500 / Kinetic scrolling loses smoothness at bottom/top

Version: r28878

Hello again!

I've got another ( :-) ) complaint about kinetic scrolling on mr500:
On big lists, when you reach one end (top/bottom), the kinetic scrolling function loses its smoothness and the content jumps like a magnet to the borders.

This bug is reproducable with the simulator.

I've also done a screenshot, what I found strange …

   cats.png (156.5 KiB)
Closed by  kugel.
2011-06-05 15:15
Reason for closing:  Later
Additional comments about closing:  

Anyone who wants this fixed, please provide a patch. I'm not motivated to fix it and have no time currently.

IMO this is rather convenient since it marks the end of a list. I didn't implement it intentionally but I didn't bother fixing it because I quite like it.

To be honest, on the mr500 this looks like a disturbing glitch, because when the described case occurs, the first line-entry disappears and the hole content jekrs (for a moment ).

I propose at least to implement this *intentionally* ;-) or add an option in the settings to deactivate this.

If it means anything I vote no, there is to much code to go through as it is, and it enhances nothing really.

Maybe this behavoiur is nice/convenient on Android,
but I've tested also Cowon D2-Simulator … and this glitch is (still) annoying too :'(

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing