Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Plugins
  • Assigned To No-one
  • Operating System iPod 5G
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by captainkewl - 2011-01-11
Last edited by speachy - 2024-04-21

FS#11866 - Mikmod segfaults when playing a directory which contains a mod file

This appears to happen only on the simulator, as of r29012.

Fill a directory with, say, some .s3m files and .mod files. Mikmod plugin chokes on calloc (virtch.c, line 1227) during MikMod_Init() sequence.

Remove the .mod files and the plugin loads and works properly.

Reverting the change made to viewers.config in r29012 seems to fix this. I’m guessing the problem is somehow related to the way mod is both playable and viewable, but there’s nothing obviously wrong with viewers.config that I can see. Maybe the buffers are getting screwed up somewhere in filetypes.c?

Closed by  speachy
2024-04-21 01:11
Reason for closing:  Out of Date
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

This ticket is 13 years old, and since then I've personally updated the mikmod codebase multiple times.

We can re-file if it's still an issue.

The above was posted after using 64 bit Ubuntu. Just tested in 32 bit; works fine. Alignment issue?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing