Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Recording
  • Assigned To No-one
  • Operating System
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by bu88a1 - 2003-04-10
Last edited by bagder - 2004-03-17

FS#1189 - Recording bug MP3 first frame?

I recorded a show last night and tried to edit the tracks
this morning.

I found that the recordings play in Media Jukebox, Real
Player, and the Archos.

BUT…

and was unable to load the mp3 files in either
Soundforge or MP3 Direct Cut for editing.

Model: Recorder 20
Daily build: 04-09-2003

Record settings: Quality - 7

                 Frequency - 44.1
                 Source    - line in
                 Channels  - stereo

recorded 4 files.

R030409202926.mp3 730KB
R030409203007.mp3 73,691KB
R030409220149.mp3 5,812KB
R030409220637.mp3 89,152KB

All 4 will play

All 4 will not load in
SoundForge 4.5
Error: “Unable to decode file.”

	"The file is not an MP3 file or 

contains corrupted

information." 

MP3 Direct Cut 1.3 File will load.

			Displays no 

data for the first 2-3 seconds of

			the file
			        
Closed by  bagder
2004-03-17 08:22
Reason for closing:  Fixed
Additional comments about closing:  

Logged In: YES
user_id=1110

This bug report is about the initial zeroes that linus later
fixed to create an id3 tag instead.

If you experience OTHER mp3-related bugs, file them as new
bug reports.

Smallest mp3 of listed files is 730KB.
Can not attach.
Reach me via e-mail I will foward.

Project Manager

This is because files recorded with Rockbox reserve 4Kbytes
of data in the beginning of the file for ID3 info plus a
Xing header. This block is currently filled with 0’s. That
seems to confuse those editors.

Some day we will add real ID3 tags…

Project Manager

The latest daily build adds an ID3 tag instead of just 0’s.
How does you editor handle it?

More discovery of mp3 recording revealed a silent section of
the recording at app 1 hour into the second set. It sounds as
though the disk did not respond fast enough for the data.
Listen to the attached mp3 for the error.

I am experiencing the same problem:
MAGIX Audio Cleaning Lab 2004 does not open the MP3 I
recorded.

Archos Recorder 20.
Rockbox 2.0

Anonymous Submitter commented on 2003-09-18 19:03

use mp3 tag tools from http://sourceforge.
net/projects/massid3lib to remove the id3 tags, works for me.

not a proper fix to the problem i know but it does the trick.

HuwSy

Project Manager

This bug report is about the initial zeroes that linus later
fixed to create an id3 tag instead.

If you experience OTHER mp3-related bugs, file them as new
bug reports.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing