Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Drivers
  • Assigned To No-one
  • Operating System iPod Nano 2G
  • Severity High
  • Priority Very Low
  • Reported Version Release 3.7.1
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Buschel - 2011-01-28
Last edited by Buschel - 2011-04-22

FS#11911 - issues with nano 2g display

As reported in http://forums.rockbox.org/index.php/topic,27098.0.html there were issues with the nano 2g LCD reported (see Forum thread or attachment for a photo).

The following information has been collected so far:


revisions


working → r25375-100328
non-working → current (something after the latest speed optimizations)


LCD type


From diagmode it shows:
LCD Detect0:1
LCD Detect1:0

Also in hardware debug:
LCD:
type: 1, (7) LDS176

Closed by  Buschel
2011-04-22 20:42
Reason for closing:  Fixed
Additional comments about closing:  

Fixed with r29764.

MikeS commented on 2011-03-10 20:54

I took a quick look in there out of curiosity and I found it odd that it does no clipping of drawing parameters.

Michael, can you explain in more detail what you found in the code?
Another hint might be  FS#11997 . As the above image shows a working status bar I am not covinced that this is a driver issue. Maybe it is an effect of viewports?

MikeS commented on 2011-03-13 08:12

Just that really. I don’t know the code very well but other drivers clip and out of range parameters would cause bad register values as well as invalid framebuffer addresses. My own initial strategy would be to just put some clipping code in there and see since code assumes the driver will clip the screen updates. If that didn’t solve the problem, I’d still leave the clipping code there since then you know that won’t be a continuing possibility and keep trying whatever came to mind.

Two more reports:
http://forums.rockbox.org/index.php/topic,27777.0.html http://forums.rockbox.org/index.php/topic,27813.0.html

The issue could be reproduced and the underlying cause was identified as insufficient voltage supply of the LCD. A voltage supply of 2.8V was tested and verified to be sufficient for one of the users with a problematic iPod nano 2G.

The change which lowered the voltage supply from 3.0V (Apple OF) to 2.6V (svn before r29764) was submitted to get rid of a buzz noise that the LCD is generating. With the new 2.8V setting this buzz is still significantly lower as with Apple OF.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing