Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Patches
  • Category Infrastructure → Build environment
  • Assigned To
    linuxstb
  • Operating System Generic RaaA
  • Severity Low
  • Priority Very Low
  • Reported Version Release 3.7.1
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by linuxstb - 2011-02-24
Last edited by linuxstb - 2011-02-27

FS#11966 - Use separate modelnames and config files for RaaA

This patch is a continuation of r29286 to make RaaA builds more similar to regular targets.

It changes tools/configure to use a unique “modelname” for each target, instead of them all being called “application”. It also splits the config/application.h file into separate files for each target, with the same name as $modelname.

tools/buildzip.pl checked for ($modelname eq ‘application’) so this has been changed to pass a –app parameter instead. When this is set to “yes”, then buildzip.pl should behave the same as when $modelname was set to “application”.

However, there seems to be a bug in my changes to buildzip.pl - “make zip” for an android build now fails, with wpsbuild.pl (called from buildzip.pl) trying to create a “/.rockbox” directory. I haven’t had time to fix this yet - help welcome.

NOTE: Due to SVN not dealing with my use of “svn cp”, you need to do the following before applying this patch:

cp firmware/export/config/application.h firmware/export/config/android.h
cp firmware/export/config/application.h firmware/export/config/nokian900.h
cp firmware/export/config/application.h firmware/export/config/nokian8xx.h
cp firmware/export/config/application.h firmware/export/config/sdlapp.h

Closed by  linuxstb
2011-02-27 11:38
Reason for closing:  Accepted
Additional comments about closing:  

Committed as r29418

Patch updated to r29236

I’ve tracked down the bug with buildzip.pl. It is caused by the line in current SVN which defines $app to be “($modelname eq “application”). This turns out to only be true for the *install: targets in root.make, as the other targets (e.g. zip) add backslashes to the modelname, meaning it contains the value “\”application\”“. The attached patch fixes this by explicitly checking for $install when stripping the leading / - the only place outside the make_install() function where $app is checked.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing