Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 FS#11990 : Data abort with .fms files that show FM station logo

Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface → Themes
  • Assigned To No-one
  • Operating System Sansa AMSv2
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by eevan - 2011-03-04
Last edited by mc2739 - 2011-03-29

FS#11990 - Data abort with .fms files that show FM station logo

I noticed this problem on my Fuze v2 some time ago and it’s present in current build (r29513). A few months ago, the same .fms worked correctly.

I get the following data abort every time I start the FM radio:

Data abort
at 30008244
FSR 0×8 (domain 0, fault 8)
address 0x54646E4D

The player behaves normally when I comment the line in .fms that shows the .bmp logo
Please, see this thread (http://forums.rockbox.org/index.php?topic=27272) for the .fms file I use.

Since I also own Sansa c200v1, I tested similar .fms (appropriate for c200’s screen size) , and the error does not occur on it, logos are displayed correctly. So I suspect that not all players have this issue.

Closed by  mc2739
2011-03-29 22:49
Reason for closing:  Fixed
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

Fixed with r29599

On sansa e200 v1 FM screen with themed fms with station logo the data abort happens at 00008914
This started to happen with version 3.8. It worked fine in 3.7.1.

Please try a current build. This bug appears to be fixed as of r29599.

eevan commented on 2011-03-29 16:58

Yes indeed, r29599 fixed the problem on Fuze v2! So maybe, this bug report should be closed…

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing