Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface
  • Assigned To No-one
  • Operating System Iriver H300 series
  • Severity Low
  • Priority Very Low
  • Reported Version Release 3.8
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by junkie - 2011-03-08
Last edited by Buschel - 2011-12-22

FS#11997 - Album Art corrupted since 3.8 with some WPS

Album art display is corrupted if taken from a separate image (i.e. cover.bmp or cover.jpg)

Closed by  Buschel
2011-12-22 19:34
Reason for closing:  Out of Date
Additional comments about closing:  

No further info since 9 months.

2013-11-21: A request to reopen the task has been made. Reason for request: FYI, still happening with 3.12 and 75x75 cover.bmp artwork and Cabbie Enhanced+ theme. 75x75 artwork works fine with cabbiev2, but needs to be at least 100x100 to work with Enhanced+. I haven't tried 3.13 as I'm not sure that the 10 band EQ will work with my old H3xx.

Correction: It only affects bmp files. Might be an issue with scaling them.

I did a quick test with the simulator and a cover.bmp file. There is no issue, even not when rescaling the bmp. v3.8 introduced embedded album art, does you file have a tag containing such embedded image?

Hi Andree,
I’ve attached two files that get corrupted on display. In one case the music files are ogg vorbis, in the other they are mp3 without embedded album art.

Hmm, both files do not have any issue on my sim (iPod nano 2g). Both are scaling to 100×100 for my WPS.

Did you try to use a current svn to crosscheck whether you bug might be related to v3.8 only?

The files did display correctly with 3.7.1. The corruption started with 3.8. Now I’m running r29539 and the problem persists. Also I tried two WPS: Air (my standard one) and Cabbie Enhanced+ to check if it might be an incompatibility in the theme. The problem seems to be independent of the WPS used.

Just tried with Cabbie V2 and that did display the album art OK. Have there been changes to handling the album art WPS code from 3.7.1 to 3.8 and later?

I’ve also noticed that album art isn’t working with some themes as of 3.8 on my Ipod Nano 1G. I’m running r29534 right now. It appears that themes using image sizes of 100×100 or 65×65 will scale the image and display it on the WPS screen without a problem, but themes using other image sizes don’t display the album image.

I tested a couple of other themes for the nano 1g. It looks like the album art will work for any of the wps files I tried as long as I reboot rockbox after loading the wps file, so I don’t think the problem is dependent on the wps image size.

Reiner, David, can each of you please attach a theme that shows this error? Maybe also screenshot or photo of the corrupted bitmap?
Maybe this is also related to  FS#11911 

Andree, here are two pictures (hopefully clear enough as the camera didn’t allow me to go closer) of my H300’s display. One (11032011018.jpg) is with Cabbie V2 theme, showing the album art as it is supposed to look. The other (11032011016.jpg) is with Air theme, showing the same album art (same bmp file) but corrupted.

As you can see it doesn’t look anything like  FS#11911 . Could it be that upscaling is broken in 3.8+, while downscaling and no scaling are still OK?

I can upscale or downscale those images without any issue on my nano 2g sim. Therefor I do not think this is a general issue. I will try to get some WPS-specialist involved here.

My problem with the album art images is that they either display correctly or not at all. This sounds like a different issue from Reiner’s problem. I’ll submit a separate bug report when I can find a consistent way to duplicate the problem.

I tried reproduce this with the rockbox simulator for the H300. The album art displays correctly with Cabbie V2. However, the WPS of Air would not display, i.e. the background and the fixed part at the top are there OK, but the main section with album art and song info and status part at the bottom do not appear. Those are replaced by text-only default standard.

So, Cabbie V2 works on both, H300 and simulator. Air works on H300 but with gobbled-up album art as in 11032011018.jpg above and does not load properly on the simulator. I didn’t yet try a back-to-back with Cabbie Enhanced+.

As it all used to work with 3.7.1, can someone please explain what has changed in WPS interpretation from 3.7.1 to 3.8?

As a workaround I’m going to update all my album art to JPGs, which are larger than used in the WPS. This means they down-scale properly. MusicBrainz Picard is great for doing that. Using those small BMPs was anyway a bit outdated ;-)

Is this still happening? If so, can you please provide the theme that causes those errors?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing