Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface → Simulator
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Release 3.8
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by fg - 2011-03-28
Last edited by dreamlayers - 2011-12-05

FS#12032 - disktidy crashes in the simulator

The problem seems to be that while sim_readdir() uses struct sim_dirent, disktidy.c uses the host dirent structure, and those are different

Closed by  dreamlayers
2011-12-05 17:39
Reason for closing:  Fixed
Additional comments about closing:  

Fixed in r31089 via  FS#12414 

The problem is that plugin.c sets readdir (and friends) to sim_readdir, which is wrong if the target has dircache. For dircache it needs to be readdir_cached (which internally calls readdir_uncached aka sim_readdir).

I have gathered some more information concerning this bug.

1. md5sum, random_folder_advance_config, stats, and properties also have problems (segfault) in the simulator
2. the w32 crosscompiled sim also crashes when these plugins are run
3. disabling dircache does not help
4. bisecting shows the first failing revision to be r28929

Does r31089 fix this?

Fred,

The listed plugins now function correctly.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing