Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Codecs
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Release 3.8
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by saratoga - 2011-04-06
Last edited by Buschel - 2011-05-02

FS#12046 - MP4 parser robustness: error on certain files

http://184.168.139.11/non_working.m4a

mp4.c errors out with “MP4 metadata error. errno 22, samples 9507840, frequency 44100. filesize 0”.

Plays in other software without error.

Closed by  Buschel
2011-05-02 07:19
Reason for closing:  Not a Bug
Additional comments about closing:  

The reported file has a major defect.

The parser does not find the existing “mdat” frame. This “mdat” frame is present and located late in the m4a header. I will further investigate.

The files itself is broken. The first “free” frame indicates a wrong length (0xC07A). If the correct length is indicated (0×17928) the files plays fine.

I have uploaded the file with this simple change: http://www.sendspace.com/file/5c5ng5

So, our parser does not have any bug, but is not as error resilient as others…

Edit: The header has two sets of metadata (album, title, etc.). The 2nd one is not placed correctly and preceeded by several kilobytes of data (audio stream?). Seems like a tagger has messed up the file…

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing