Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface
  • Assigned To No-one
  • Operating System iPod 5G
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by lovasoa - 2011-04-06
Last edited by speachy - 2024-04-01

FS#12047 - WPS on startup doesn't work on iPod Video

On my iPod video, when I choose to load the WPS on startup (either in the Settings menu or in the alarm menu), it doesn’t work. The player stays on the main (root?) screen.

I had to tweak root_menu.c (which I join) to get the alarm to work with the WPS. This is not a patch, but a quick and dirty workaround that I did just to be waked up on time tomorrow…

Closed by  speachy
2024-04-01 00:21
Reason for closing:  Not a Bug
St. commented on 2011-04-09 10:41

Would it be possible *to* provide a patch, so that we don't have to pull your file, then diff it against svn just to see what it is that you've changed?

[St.]

I'm not on my computer at the moment, so I don't have diff. But I can tell you what I changed :
In the root_menu function, there is the following:
#ifdef HAVE_RTC_ALARM
    if ( rtc_check_alarm_started(true) ) 
    {
        rtc_enable_alarm(false);
        next_screen = GO_TO_WPS;

That I replaced with:
#ifdef HAVE_RTC_ALARM
    if ( rtc_check_alarm_started(true) ) 
    {
        rtc_enable_alarm(false);
        //next_screen = GO_TO_WPS;
        next_screen = GO_TO_PREVIOUS_MUSIC;

I saw in the header file that GO_TO_PREVIOUS_MUSIC was deprecated. But at the moment, it works…

Did your playlist finish? if it did then it doesnt really make sense to go into the WPS at startup.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing