Rockbox

Tasklist

FS#12086 - SPC files won't seek

Attached to Project: Rockbox
Opened by Benjamin Samuel (Dodecahedron) - Saturday, 30 April 2011, 00:36 GMT
Last edited by Michael Sevakis (MikeS) - Saturday, 30 April 2011, 13:34 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Release 3.8.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

SPC files won't seek. Attempting to fast forward a track results in nothing other than playback continuing from the same section of the track.
This task depends upon

Closed by  Michael Sevakis (MikeS)
Saturday, 30 April 2011, 13:34 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  Just isn't practical to implement without emulator state "keyframes".
Comment by Michael Sevakis (MikeS) - Saturday, 30 April 2011, 13:34 GMT
Seeking SPC is nontrivial since if going forward, it must be emulated from the current position to the final position, and if going backwards, from the beginning of the song to the final position, thus it would be really, really slow in the majority of cases.

Loading...