Rockbox

Tasklist

FS#12091 - .m4a songs not playing on ipod video(5th gen)

Attached to Project: Rockbox
Opened by Rocco Manley (Kalriszian) - Monday, 02 May 2011, 05:33 GMT
Last edited by Andree Buschmann (Buschel) - Monday, 02 May 2011, 07:48 GMT
Task Type Bugs
Category Codecs
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity Low
Priority Normal
Reported Version Release 3.8.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The problem seems to be getting my aac(m4a) files to play... every time I selected one to play, I would get a ''Data abort at 0003FD80 (0)'' screen. I figured that there must be a problem with the aac codec included in the rockbox installation, so I decided to replace the codec list with one from the current build for ipod video (5th gen). All went smoothly but the aac files would still crash the system each time one was selected.... Any ideas?

I have also tried updating the entire system to the latest build and back to 3.8.1 multiple times with no success.. Any help would be greatly appreciated! Thanks

I've included a sample track that doesn't play.
This task depends upon

Closed by  Andree Buschmann (Buschel)
Monday, 02 May 2011, 07:48 GMT
Reason for closing:  Rejected
Additional comments about closing:  Not a rockbox issue. Failure was caused by file corruption.
Comment by Andree Buschmann (Buschel) - Monday, 02 May 2011, 05:44 GMT
The is no sample track available yet.

Can you tell us what exact version you are using?
Comment by Rocco Manley (Kalriszian) - Monday, 02 May 2011, 05:54 GMT
Oops sorry about that.. my internet is always skipping on me like that! Here it is

Exact version is r29804-110501
Comment by Andree Buschmann (Buschel) - Monday, 02 May 2011, 06:04 GMT
This tracker allows to attach files up to 2 MB. If the file is larger you might need to upload it to a filesharing site and place a link here.

Question: Does the official release 3.8.1 (or any other older release) work for you?
Comment by Rocco Manley (Kalriszian) - Monday, 02 May 2011, 06:12 GMT
Wow, I didn't even notice the limit.. sleepiness creeping in slowly.

Here is the fileshare link

http://www.4shared.com/audio/vcixDT2o/07_Alphabet_Aerobics__The_Cut_.html

Hopefully it works!

Comment by Rocco Manley (Kalriszian) - Monday, 02 May 2011, 06:14 GMT
I'll try an older release and report back
Comment by MichaelGiacomelli (saratoga) - Monday, 02 May 2011, 06:18 GMT
Heres a direct link:

http://duke.edu/~mgg6/rockbox/07%20Alphabet%20Aerobics%20(The%20Cut%20Chemis.m4a

FWIW the file plays fine for me in the Sim, e200v1, and the Clip+ using a current and circa 3.7 builds.
Comment by Rocco Manley (Kalriszian) - Monday, 02 May 2011, 06:45 GMT
No go on the trying out an older version. It seems the archive of old releases only has up to rockbox 2.5 from Sept 2005, which came out before the ipod 5th gen was released.. the installer looks to be designed for only the Archos Ondio and Jukebox players..
Comment by Rocco Manley (Kalriszian) - Monday, 02 May 2011, 06:48 GMT
Never mind I found the thread for newer releases...
Comment by Andree Buschmann (Buschel) - Monday, 02 May 2011, 06:59 GMT
Like for saratoga the file plays fine on my simulation as well. I will be able test on my iPod 5G tonight (in ~11h). Until then it would be great if you could check your iPod HDD for file system corruption.
Comment by Rocco Manley (Kalriszian) - Monday, 02 May 2011, 07:43 GMT
Got it to work with a fresh installation after a full wipe of the system.. I guess this can be closed now

Loading...