• Status Closed
  • Percent Complete
  • Task Type Bugs
  • Category Rbutil
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Release 3.8.1
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by KevanGC - 2011-05-09
Last edited by bluebrother - 2012-02-06

FS#12106 - Rockbox Utility V1.2.10 doesn't let me create voice files


I’ve been trying to make a voicefile for my Sansa Fuze V2. I used the SAPI5 engine with a NeoSpeech voice. It’s a big voice but it sounds great.

In Rockbox utility 1.2.8, it would do it half the time, and sometimes it would give an error. I guess it’s because the voice is so big, it takes up lots of memory.

However, in the new 1.2.10 utility, i’m completely unsuccessful in creating voicefiles with this voice. It always gives an error. It says encoding of “C:/Users/KevanGC/AppData/Local/Temp/rbvoice//random file name.wav”” failed. It gives a random filename, I guess because it’s trying to encode the .wav files, taking too much memory, and getting stuck on a random file.

Rockbox utility version 1.2.8 did the same thing, but only half the time with the settings set exactly the same. The new V1.2.10 does it every time I try, but I’m able to create voice files on it just fine if I use a different voice.

The NeoSpeech voice does work correctly. I’ll attach one of the logs it gave me so you can get more info.

I’m just wondering, since the old utility worked half the time, and the new one doesn’t work at all, does the new one use more memory?


Closed by  bluebrother
2012-02-06 19:02
Reason for closing:  Fixed
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

Multithreading support for voicefile generation has been removed, will be re-added later.

This has nothing to do with memory usage. See  FS#11994  – it was supposed to be fixed, but it seems that disabling running the TTS engine with more than one thread (which is the change why it is running slower) didn’t help. Interestingly said change didn’t make the problem occur anymore for me. Can you reproduce the problem with a different voice (especially the one shipped with Windows, MS Sam / MS Anna)?

It works fine on MS Anna. Probably because it’s a smaller voice. I still want to use NeoSpeech Julie as it sounds a lot better than Anna.

Is a good workaround to use rbutil 1.2.6 for now?

V1.2.8 is the only thing I have that lets me create voice files.

I can reproduce the problem with Loquendo as well. I think you may want to go back to the old way of doing it, the old one at least works sometimes.

I can do it consistently on 1.2.6. I reccommend you do it. I wish the makevoices.vbs script worked again.

How can I get 1.2.6? If that works fine, maybe the devs should make the next version of the utility the same way?

Go to the RButil wikipage and then find the download link for windows. Then get the address that that link points to and then change the number from 10 to 6 and you’re good to go.

Interestingly, the voicing of entries works fine and never fails. The only spot where the problem hits is when encoding the .wavs to create the voice file. I Actually think it’s working too fast making those wavs, as the CPU useage for the utility spikes on my system.

I think it might improve things to have the utility pause slightly after the creation of each .wav file.


Available keyboard shortcuts


Task Details

Task Editing