FS#12151 - RockboxUtility.exe alway crashes when loaded

Attached to Project: Rockbox
Opened by tilman (tilbee) - Thursday, 09 June 2011, 19:32 GMT
Last edited by Dominik Riebeling (bluebrother) - Monday, 11 July 2011, 17:30 GMT
Task Type Bugs
Category Battery/Charging
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Release 3.8.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I have tried to install rockbox utility 1.2.10, 1.2.9, 1.2.8 (win version) all of them crashed right seconds after starting: RockboxUtility.exe I have no clue why.

   1.png (10.9 KiB)
   2.png (9 KiB)
   3.png (9.9 KiB)
   4.png (9.4 KiB)
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Monday, 11 July 2011, 17:30 GMT
Reason for closing:  Works For Me
Additional comments about closing:  - I cannot reproduce the issue
- The details make me believe this is a problem with a 3rd party library on the Windows installation used, not a problem with Rockbox Utility.
- We never had such a report before, and I'm rather sure the accused Antivir is used by a couple of users.
Comment by tilman (tilbee) - Thursday, 09 June 2011, 19:34 GMT
It just shows the introscreen like:
then windows shows up to tell it has been crashed
Comment by tilman (tilbee) - Thursday, 09 June 2011, 20:00 GMT
After a couple of second this appears
   5.png (62.3 KiB)
Comment by Dominik Riebeling (bluebrother) - Friday, 10 June 2011, 07:28 GMT
You are still missing important information. Which OS? I don't believe this is a problem with Rockbox Utility.
Comment by tilman (tilbee) - Friday, 10 June 2011, 16:27 GMT
It is on Win XP
I have tried it on aynother win xp system there it works, bit it seems to try to connect right away with the net.
If you have proxis you need to switch to the appropriate menue first. With this machine I manged to get rockbox on my sansa clip.
Really great!! it works fine.

The xp on the rockboxutility ist not working might have to do with the proxy config or rockbox gets some data via tcp/ip that causes the crash.

I will try it on the other xp machine by starting rockboxutility from the clip player directly.
Comment by Dominik Riebeling (bluebrother) - Friday, 10 June 2011, 19:25 GMT
Please post the exact proxy configuration of your machine.
Comment by tilman (tilbee) - Friday, 10 June 2011, 20:49 GMT
maybee it interferes with avm vpn driver ( that ist installed on most network adapters
all other possibilities I tried to exclude by disabling.
next step is to remove all avm vpn miniport driver on the machine. w'll see.
Comment by tilman (tilbee) - Friday, 10 June 2011, 21:32 GMT
ok avm vpn driver is gone.
Maybee it is the avsda.dll from antivirus suite.
I already diabled the software but it seems that the antivir needs to be uninstalled completely to remove avsda from memory.
   7.png (19 KiB)
Comment by tilman (tilbee) - Friday, 10 June 2011, 21:54 GMT
StartupList report, 10.06.2011, 23:50:18
StartupList version: 1.52.2
Started from : C:\Programme\Trend Micro\HijackThis\HijackThis.EXE
Detected: Windows XP SP3 (WinNT 5.01.2600)
Detected: Internet Explorer v8.00 (8.00.6001.18702)
* Using default options

Running processes:

C:\Programme\Gemeinsame Dateien\logishrd\LVMVFM\UMVPFSrv.exe
C:\Programme\Avira\AntiVir Desktop\sched.exe
C:\Programme\Avira\AntiVir Desktop\avguard.exe
C:\Programme\Avira\AntiVir Desktop\avshadow.exe
C:\Programme\Auction Studio\Database Server\bin\fbguard.exe
C:\Programme\Auction Studio\Database Server\bin\fb_inet_server.exe
C:\Programme\Sony Ericsson\Sony Ericsson PC Suite\SupServ.exe
D:\Tobit Radio.fx\Server\rfx-server.exe
C:\Programme\Gemeinsame Dateien\Intel\WirelessCommon\RegSrvc.exe
C:\Programme\Toshiba\Bluetooth Toshiba Stack\TosBtSrv.exe
C:\Programme\Gemeinsame Dateien\Ulead Systems\DVD\ULCDRSvr.exe
C:\Programme\Avira\AntiVir Desktop\avmailc.exe
C:\Programme\Avira\AntiVir Desktop\AVWEBGRD.EXE
C:\Programme\Notebook Hardware Control\nhc.exe
C:\Programme\Citrix\ICA Client\concentr.exe
C:\Programme\Avira\AntiVir Desktop\avgnt.exe
C:\Programme\Citrix\ICA Client\wfcrun32.exe
C:\Programme\Gemeinsame Dateien\Intel\WirelessCommon\iFrmewrk.exe
C:\Programme\Elaborate Bytes\VirtualCloneDrive\VCDDaemon.exe
C:\Programme\Gemeinsame Dateien\Java\Java Update\jusched.exe
C:\Programme\Logitech\LWS\Webcam Software\LWS.exe
C:\Programme\Gemeinsame Dateien\AVerMedia\AVerQuick\AVerQuick.exe
C:\Programme\Toshiba\Bluetooth Toshiba Stack\TosBtMng.exe
C:\Programme\Logitech\LWS\Webcam Software\CameraHelperShell.exe
C:\Programme\BenQ\QMedia Center\SchSvr.exe
C:\Programme\Gemeinsame Dateien\Logishrd\LQCVFX\COCIManager.exe
C:\Programme\Toshiba\Bluetooth Toshiba Stack\TosA2dp.exe
C:\Programme\Toshiba\Bluetooth Toshiba Stack\TosBtHid.exe
C:\Programme\Toshiba\Bluetooth Toshiba Stack\TosBtHsp.exe
C:\Programme\Mozilla Firefox 4.0 Beta 7\firefox.exe
C:\Programme\Avira\AntiVir Desktop\update.exe
C:\Programme\Trend Micro\HijackThis\HijackThis.exe


Listing of startup folders:

Shell folders Startup:
[C:\Dokumente und Einstellungen\Admin\Startmenü\Programme\Autostart]
Logitech . Produktregistrierung.lnk = C:\Programme\Logitech\Ereg\eReg.exe
Netzmanager.lnk = C:\Programme\Netzmanager\netzmanager.exe

Shell folders Common Startup:
[C:\Dokumente und Einstellungen\All Users\Startmenü\Programme\Autostart]
AVerQuick.lnk = C:\Programme\Gemeinsame Dateien\AVerMedia\AVerQuick\AVerQuick.exe
Bluetooth Manager.lnk = ?
Hardcopy.LNK = C:\Programme\Hardcopy\hardcopy.exe
HOTSYNCSHORTCUTNAME.lnk = C:\Programme\Palm\Hotsync.exe
InterVideo Scheduler server.lnk = C:\Programme\BenQ\QMedia Center\SchSvr.exe
Lexware Info Service.lnk = C:\Programme\Gemeinsame Dateien\Lexware\Update Manager\LxUpdateManager.exe
phase-6 Reminder.lnk = C:\Programme\phase-6\phase-6\reminder\reminder.exe
Quicken 2011 Zahlungserinnerung.lnk = C:\Programme\Lexware\Quicken\2011\billmind.exe
Scrybe.lnk = ?
WISO Mein Sparbuch heute.lnk = C:\Programme\WISO\Sparbuch 2010\meinsparbuchheute.exe


Checking Windows NT UserInit:

[HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon]
UserInit = C:\WINDOWS\system32\userinit.exe,


Autorun entries from Registry:

AzMixerSel = C:\Programme\Realtek\InstallShield\AzMixerSel.exe
Q-HotkeyMgr = C:\Programme\BenQ\Q-HotkeyMgr\HotkeySensor.exe
IviRCService = C:\Programme\BenQ\Common\Bin\iviRCService.exe
IMCServerAutoStart = C:\Programme\BenQ\IMCSvr\IMCSvr.exe
CIR = C:\WINDOWS\system32\drivers\CIR.exe
NotebookHardwareControl = "C:\Programme\Notebook Hardware Control\nhc.exe" -quiet
OSSelectorReinstall = C:\Programme\Gemeinsame Dateien\Acronis\Acronis Disk Director\oss_reinstall.exe
SSBkgdUpdate = "C:\Programme\Gemeinsame Dateien\Scansoft Shared\SSBkgdUpdate\SSBkgdupdate.exe" -Embedding -boot
OpwareSE4 = "C:\Programme\ScanSoft\OmniPageSE4.0\OpwareSE4.exe"
NeroFilterCheck = C:\Programme\Gemeinsame Dateien\Ahead\Lib\NeroCheck.exe
BluetoothAuthenticationAgent = rundll32.exe bthprops.cpl,,BluetoothAuthenticationAgent
ConnectionCenter = "C:\Programme\Citrix\ICA Client\concentr.exe" /startup
avgnt = "C:\Programme\Avira\AntiVir Desktop\avgnt.exe" /min
IntelZeroConfig = "C:\Programme\Intel\WiFi\bin\ZCfgSvc.exe"
IntelWireless = "C:\Programme\Gemeinsame Dateien\Intel\WirelessCommon\iFrmewrk.exe" /tf Intel Wireless Tray
IgfxTray = C:\WINDOWS\system32\igfxtray.exe
HotKeysCmds = C:\WINDOWS\system32\hkcmd.exe
Persistence = C:\WINDOWS\system32\igfxpers.exe
LexwareInfoService = C:\Programme\Gemeinsame Dateien\Lexware\Update Manager\LxUpdateManager.exe /autostart
VirtualCloneDrive = "C:\Programme\Elaborate Bytes\VirtualCloneDrive\VCDDaemon.exe" /s
SunJavaUpdateSched = "C:\Programme\Gemeinsame Dateien\Java\Java Update\jusched.exe"
LWS = C:\Programme\Logitech\LWS\Webcam Software\LWS.exe -hide


Autorun entries from Registry:

CTFMON.EXE = C:\WINDOWS\system32\ctfmon.exe
swg = "C:\Programme\Google\GoogleToolbarNotifier\GoogleToolbarNotifier.exe"


Shell & screensaver key from C:\WINDOWS\SYSTEM.INI:

Shell=*INI section not found*
SCRNSAVE.EXE=*INI section not found*
drivers=*INI section not found*

Shell & screensaver key from Registry:

drivers=*Registry value not found*

Policies Shell key:

HKCU\..\Policies: Shell=*Registry value not found*
HKLM\..\Policies: Shell=*Registry value not found*


Enumerating Browser Helper Objects:

(no name) - C:\Programme\Google\GoogleToolbarNotifier\5.6.5612.1312\swg.dll - {AF69DE43-7D58-4638-B6FA-CE66B5AD205D}
(no name) - C:\Programme\Java\jre6\bin\jp2ssv.dll - {DBC80044-A445-435b-BC74-9C25C1C588A9}
JQSIEStartDetectorImpl - C:\Programme\Java\jre6\lib\deploy\jqs\ie\jqs_plugin.dll - {E7E6F031-17CE-4C07-BC86-EABFE594F69C}


Enumerating Task Scheduler jobs:

Alle 100 min.job
Google Software Updater.job


Enumerating Download Program Files:

[Windows Genuine Advantage Validation Tool]
InProcServer32 = C:\WINDOWS\system32\legitcheckcontrol.dll

[20-20 3D Viewer]
InProcServer32 = C:\WINDOWS\system32\20-20 Technologies\3D Viewer\v5.0.4.0\2020Player_5_0_4_0.dll

[WUWebControl Class]
InProcServer32 = C:\WINDOWS\system32\wuweb.dll

[MUWebControl Class]
InProcServer32 = C:\WINDOWS\system32\muweb.dll


[Shockwave Flash Object]
InProcServer32 = C:\WINDOWS\system32\Macromed\Flash\Flash10i.ocx

[WEBDE Fotoalbum Upload Control]
InProcServer32 = C:\WINDOWS\DOWNLO~1\upload.ocx


Enumerating Winsock LSP files:

NameSpace #4: C:\WINDOWS\system32\wshbth.dll
NameSpace #5: C:\Programme\FRITZ!DSL\\sarah.dll
Protocol #1: C:\Programme\Avira\AntiVir Desktop\avsda.dll
Protocol #2: C:\Programme\FRITZ!DSL\\sarah.dll
Protocol #3: C:\Programme\Avira\AntiVir Desktop\avsda.dll
Protocol #4: C:\Programme\FRITZ!DSL\\sarah.dll
Protocol #5: C:\Programme\FRITZ!DSL\\sarah.dll
Protocol #12: C:\Programme\Avira\AntiVir Desktop\avsda.dll
Protocol #13: C:\Programme\FRITZ!DSL\\sarah.dll


Enumerating ShellServiceObjectDelayLoad items:

PostBootReminder: C:\WINDOWS\system32\SHELL32.dll
CDBurn: C:\WINDOWS\system32\SHELL32.dll
WebCheck: C:\WINDOWS\system32\webcheck.dll
SysTray: C:\WINDOWS\system32\stobject.dll
UPnPMonitor: C:\WINDOWS\system32\upnpui.dll
WPDShServiceObj: C:\WINDOWS\system32\WPDShServiceObj.dll

End of report, 11.409 bytes
Report generated in 0,204 seconds
Comment by tilman (tilbee) - Saturday, 11 June 2011, 21:13 GMT
ok some news:
I have trensferred the rockbox utility via another computer onto the flash of the clipplayer.
To get it connected i had to tell the utility a special proxy , let's say proxy-xx.
If i let this preinstalled rockbox utility run from the flash of the sansa clip. NO PROBLEMS occur. Exept that rockbox has nio connection to the net since the proxy-xx does not work on the system I am investigating.
If I now switch within the working rockbox utilty the proxy to default the old crash is provoked with avsda.dll in the crash log.

My conclusion: it has to do how rockbox ist trying to connect to the net.
2.nd there might be a severe problem with avsda.dll from

Comment by Dominik Riebeling (bluebrother) - Saturday, 11 June 2011, 21:36 GMT
Please post the exact proxy configuration for the system the problem occurs as I asked for. Otherwise I'll close this as WORKSFORME since the information posted so far is useless.
Comment by tilman (tilbee) - Saturday, 11 June 2011, 22:20 GMT
do not be so rude!!!
have put in a lot of time to track down the problem, there is no special proxy config, the only thing is that i use avm dsl router that does not need any proxy server to be shared.
so I think my avm does not have a real proxy it is just a dsl modem router and nat
Maybe it would help to tell me how to optain proxy info in a way you accept.
a bit pissed
Comment by Dominik Riebeling (bluebrother) - Saturday, 11 June 2011, 22:57 GMT
This is an issue tracker, not a notepad. If you actually are trying to help figuring what's the problem you shouldn't just post heaps of remotely related information and instead put the information that has been asked for. I'm also not willing to debug any 3rd party software running on your machine that messes your machine up. I am willing to look into bugs in Rockbox Utilit, and each time this seems less than to be a problem of Rockbox Utility. Would you prefer me to simply ignore this issue?

Again: please post the exact information about the proxy configuration of the system. You can access them via the Internet Options / Connections / LAN Settings menu in Internet Explorer.
Comment by tilman (tilbee) - Sunday, 12 June 2011, 09:01 GMT
do not be so rude!!!
have put in a lot of time to track down the problem, there is no special proxy config, the only thing is that i use avm dsl router that does not need any proxy server to be shared.
so I think my avm does not have a real proxy it is just a dsl modem router and nat
Maybe it would help to tell me how to optain proxy info in a way you accept.
a bit pissed
Comment by tilman (tilbee) - Sunday, 12 June 2011, 09:10 GMT
upps why is my comment posted twice. fmessed up with back..... grrrr.

There is no proxy server in the LAN-Settings indicated or filled in.
In the upper section there is only the adress of the avm fritz box.

Also i give you my ip config:

Ethernetadapter LAN-Verbindung:

Verbindungsspezifisches DNS-Suffix:
IP-Adresse. . . . . . . . . . . . :
Subnetzmaske. . . . . . . . . . . :
IP-Adresse. . . . . . . . . . . . : 2002:4fdc:d52e:0:bd4b:6456:xxxx:xxxx

IP-Adresse. . . . . . . . . . . . : 2002:4fdc:d52e:0:240:d0ff:xxxx:xxxx
IP-Adresse. . . . . . . . . . . . : fe80::240:d0ff:fea3:1743%4
Standardgateway . . . . . . . . . :

Ethernetadapter Drahtlose Netzwerkverbindung:

Medienstatus. . . . . . . . . . . : Es besteht keine Verbindung

Tunneladapter Teredo Tunneling Pseudo-Interface:

Verbindungsspezifisches DNS-Suffix:
IP-Adresse. . . . . . . . . . . . : fe80::ffff:ffff:fffd%6
Standardgateway . . . . . . . . . :

Tunneladapter Automatic Tunneling Pseudo-Interface:

Verbindungsspezifisches DNS-Suffix:
IP-Adresse. . . . . . . . . . . . : fe80::5efe:
Standardgateway . . . . . . . . . :
   8.png (10.7 KiB)