Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Rbutil
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Rbutil 1.2.7
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
    • Pol (2014-03-10)
  • Private
Attached to Project: Rockbox
Opened by Chris - 2011-06-24
Last edited by Dominik Riebeling - 2011-06-25

FS#12166 - Rbutil proxy settings cleared if password contains @

What behaviour you are seeing:
- Proxy settings are cleared if an @ is used in the password

What behaviour you expected:
- Proxy settings saved and used properly

How to reproduce the bug:
- Specify proxy / port / username / password without @ symbol, works fine
- Add @ to the password and save, go back to proxy settings and everything is blank

This is in rbutil 1.2.10, there was no option to choose that instead of 1.2.7. Searched for anything relating to “proxy” and found no bugs detailing this issue.

Closed by  Dominik Riebeling
2011-06-25 17:21
Reason for closing:  Fixed
Additional comments about closing:  

should be ok in svn now, thanks for reporting.

Dominik Riebeling commented on 2011-06-25 13:33

This is indeed a problem and caused by the configuration file storing the proxy configuration as string – the values aren’t lost, but restoring them fails because there is no way to separate them properly anymore. A similar issue appears when the password (or username) contains a colon.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing