Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Rbutil
  • Assigned To No-one
  • Operating System iPod Mini
  • Severity Low
  • Priority Very Low
  • Reported Version Rbutil git
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by auctionlurker - 2011-07-10
Last edited by bluebrother - 2011-07-16

FS#12187 - rockbox utility install failed not recognizing installed CF card

RockboxUtility-v1.2.10

It has been a while since I updated my IPOD Mini G2.

It has had a compactflash card inside of it for several years with no problems.

I am contemplating upgrading to a newer 128GB CF card (max’ing out the capacity) and so I thought about first checking out the latest RB release.

I used several utilities to check the IPOD’s media with everything checking out 100 percent OK,.. except for 6 lightly frag’ged files, so I defrag’ged all 6 files :_)
Then unmounted and disconnect the IPOD, then reconnected the IPOD and re-ran the utilities… which reported everything 100 percent ok with 0 fragged files.

The RbUtility reports that it can not recognize the media, yet an earlier RBU version had no problems, it also properly recognizes the IPOD Mini G2.

Am including the log file inside a .zip

Closed by  bluebrother
2011-07-16 08:18
Reason for closing:  Not a Bug
Additional comments about closing:  

user error.

Rockbox Utility is more strict when checking for the correct drive to install the bootloader to than it was in the past.

What exactly does “can not recognize the media” mean? And which “earlier RBU” does work? I have a pretty similar setup (mini 2g with CF) and use that regularly without any problems. Does the Ipod recognize the disk? Are you absolutely sure you picked the correct drive for the Ipod?

Oh, and another question: what are those “several utilities”? Do those check the data partition or do they also check the firmware partition?

“can not recognize the media” is exactly what RBU states when it is run, that it can not recognize the media and will not install anything. I included a copy of RBU’s error log.

Yes. The IPOD recognizes the disk. I have used the mini 2G form some time now, without any upgrades.

To test after getting the error message from RBU I flipped back and fourth between rockbox and Apple’s OS, with utterly no problems. In fact I used it for about 12 hours yesterday with no problems.

I am of the if it ain’t broke then don’t fix it mentality… so it has been some time since I used RBU… I do not remember which RBU version, however it installed v3.6 of rockbox.

Testing software I used are:
Windows own diskcheck. (including CHKDSK under DOS).
Auslogics Disk Defrag.
MiniTool Partition Wizard.
SoftAmbulance Partition Doctor.
HDDSCAN.

Between them they scan and analyze and work with pretty much everything when it comes to storage media.

I used to build systems some years back, and I used to sell MP3 players which I modified to larger capacities (including to CF cards), including IPODs and Archos.

I use older computers for fun things, like music, etc… and save my newer for games under windoze. I use my laptop for more important things, under the Ubuntu Linux OS.

Have been using RB since very early on. So not a newbie.

So I do know how to test equipment :-)

Now however I am mostly retired.

Like I stated everything comes back OK.

The IPOD currently works just fine.
Except the fact that my capacity needs upgrading to 128GB.
And RBU stating what RBU is stating.

Ran RBU several times with the same response from RBU.

Anything else?

There is no “can not recognize the media” string in Rockbox Utility. If that’s the exact string you see it needs to come from somewhere else. Furthermore, the log file shows that the selected drive for the Ipod is F: but F: has around 100GiB free space. Unless you already changed the drive (which, as far as I understand your report, isn’t the case yet) this can’t be the Ipod and my guess would be that the correct drive is G: instead. If you selected the wrong drive you should also get a different error message saying that there is an error with the partition table. That’s exactly what happens for me if I try to install on a non-ipod.

After re-reading the log I noticed the exact error message I was expecting: “Error reading partition table - possibly not an Ipod”

Which means that you either have a drive selected that doesn’t have the Ipod disk layout or isn’t the Ipod at all. Please check the selected drive. Still, my guess is that G: would be the correct one, not F:.

“can not recognize the media” is exactly what RBU states when it is run, that it can not recognize the media and will not install anything. I included a copy of RBU’s error log.

Yes. The IPOD recognizes the disk. I have used the mini 2G form some time now, without any upgrades.

To test after getting the error message from RBU I flipped back and fourth between rockbox and Apple’s OS, with utterly no problems. In fact I used it for about 12 hours yesterday with no problems.

I am of the if it ain’t broke then don’t fix it mentality… so it has been some time since I used RBU… I do not remember which RBU version, however it installed v3.6 of rockbox.

Testing software I used are:
Windows own diskcheck. (including CHKDSK under DOS).
Auslogics Disk Defrag.
MiniTool Partition Wizard.
SoftAmbulance Partition Doctor.
HDDSCAN.

Between them they scan and analyze and work with pretty much everything when it comes to storage media.

I used to build systems some years back, and I used to sell MP3 players which I modified to larger capacities (including to CF cards), including IPODs and Archos.

I use older computers for fun things, like music, etc… and save my newer for games under windoze. I use my laptop for more important things, under the Ubuntu Linux OS.

Have been using RB since very early on. So not a newbie.

So I do know how to test equipment :-)

Now however I am mostly retired.

Like I stated everything comes back OK.

The IPOD currently works just fine.
Except the fact that my capacity needs upgrading to 128GB.
And RBU stating what RBU is stating.

Ran RBU several times with the same response from RBU.

Anything else?

Feel like shooting myself.

The problem is that I KNOW I selected G drive right off the bat, and did not give it another thought.

Scrub this one, maybe operator error, but I still state I selected G drive… oh well.

Update went just fine this time around. I will play around with 3.9 before buying the new 128GB CF card.

Thanks!

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing