FS#12195 - Uninformative error message while installing on nano 2G

Attached to Project: Rockbox
Opened by menachem shapiro (menachem) - Sunday, 24 July 2011, 04:48 GMT
Last edited by Dominik Riebeling (bluebrother) - Tuesday, 26 July 2011, 20:57 GMT
Task Type Bugs
Category Rbutil
Status Closed
Assigned To No-one
Operating System iPod Nano
Severity Low
Priority Normal
Reported Version Release 3.8.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Using Rockbox Utility, I just tried to install rockbox on the ipod nano 2G for the first time. The bootloader patched fine, but the installer errored out when trying to extract rockbox to the ipod.

Here's what it said (as you can see in the attached log):
Downloading bootloader file
Download finished.
Installing Rockbox bootloader
Successfull added bootloader
Creating installation log
Installation log created
Bootloader Installation complete.
Downloading file
Download finished.
Extracting file.
Creating output path failed
Extraction failed!

I figured out that the reason creating th output path failed was because I ran out of room on the ipod. I deleted some files and re-ran the installer and it worked fine.

It would be nice if the Rockbox Utility could figure out if there was enough room on the drive before attempting the install, and maybe telling you that it won't try the install because there's not enough room on the drive. Or at least let you know that it failed because it ran out of room.
   fail.log (38.5 KiB)
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Tuesday, 26 July 2011, 20:57 GMT
Reason for closing:  Fixed
Additional comments about closing:  Rockbox Utility now takes the cluster size into account when calculating the extracted size of the downloaded zip file.

I still believe the original behaviour observed is not a bug. However, improving it is always a good thing. Besides, a user should always consider any software to need some room to "breathe".
Comment by MichaelGiacomelli (saratoga) - Sunday, 24 July 2011, 19:11 GMT
Perhaps rockbox utility should warn on install if theres less then 15MB of free space.
Comment by Dominik Riebeling (bluebrother) - Monday, 25 July 2011, 07:23 GMT
Rockbox Utility does check the free space before installing. It even adds some headroom to compensate for loss due to cluster sizes. That headroom might be a bit too tight, but coding a fixed size is a bad idea. As you can clearly see from the log it does check the size (and there is enough space, though it's pretty tight) and then runs into a problem trying to write a file. This raises the question if your player has filesystem errors. Please run fsck.vfat on the data partition.

In either case, your player running out of disk space is not a bug in Rockbox Utility.
Comment by menachem shapiro (menachem) - Monday, 25 July 2011, 12:48 GMT
I have attached output of fsck.vfat.

It did not find any bad clusters, but it did say that the free cluster summary was wrong. I don't know if this was also the case before I deleted some stuff to make room for the install.

I wasn't saying that the player running out of room was a bug in Rockbox Utility, I was saying that the error message it gave when failing to extract rockbox to the player due to lack of room was unhelpful, and could be improved. Especially when installing Rockbox for the first time on the device (as I was doing), it was a little nerve-wracking to be told that the installation failed.

I didn't know that Rockbox Utility already checks the amount of space left on the device and calculates if there is enough room to install Rockbox. It didn't work in my case, however. Perhaps the free space calculation needs to be a little more conservative. Or perhaps a warning should be displayed in cases where the amount of free space is so close to the amount of space rockbox is supposed to take up.
   fsck.log (0.9 KiB)