• Status Unconfirmed
  • Percent Complete
  • Task Type Bugs
  • Category Codecs
  • Assigned To No-one
  • Operating System Sansa AMSv2
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by sleepypedro - 2011-07-28

FS#12208 - Sansa Clip v2 FLAC playback skips regularly

I am reopening  FS#11501  - Sansa Clip v2 FLAC playback skips regularly, which was closed because a sample file was not provided. I didn't think this was necessary because I stated it happened regularly with just about any file.

I am currently on build 30217. It skipped for me last night on this track:

I cannot attach the track to this ticket because it is larger than 2mb.

Again, it is nothing inherent in that track: a second playthrough did not skip. That 16-bit/44.1khz track was generated with FLAC 1.2.1b using normal procedures.

This problem has occurred for any build I've ever tried on a clip v2 player.

Here is my original problem statement:

Build 27566 (and all previous builds), Sansa Clip v2.

playback of 16-bit/44khz FLAC format regularly will skip ahead to next track.

in a 60 minute playback session, it'll probably happen 2-3 times. this is not due to a defect in the FLAC files. it happens with any FLAC set I attempt.

this does not happen with the Clip v1 on the same build number.

this is my first bug submitted. I searched for duplicate reports but didn't find anything.

thank you!

This happens to me too on a daily basis.
It's usually never the same track twice.

I've done a CHKDSK and everything seems fine. The FLACs also play without any errors in any other player I've tried so far.

I've used the 3.10 Installer with the 01.02.16 Clip+ Firmware. Device is a 8GB Clip+

I have the same, identical problem. I'm starting to think that this problem was linked with cover art files (Like folder.jpg), so I deleted it from every folder with FLAC files… since I made this operation, this problem never occurs… to be sure that is not a "coincidence", users with this problem have to verify that this problem occurs with or without loading a cover art.

This problem is occuring for me in filesets with no cover art. Most .flac filesets that I listen to are live concerts downloaded from, and cover art is generally not included with those sets as these are not official releases.

So, there's no cover art, not embedded nor external files like front.jpg, folder.jpg?
So Rockbox DOESN'T LOAD any image when reproducing files?

How do you copy files on Clip? Do you boot Rockbox or Original Sansa Software when you plug Clip in USB port?

Well, I think that one day we will convert our FLAC files in M4A if they will be not able to resolve this problem :(

A question for you: have you activated log?

No, I have not activated log.
I think most folders only contain .flac files, no .jpg. Most songs shouldn't have any cover art integrated.

This problem is currently very persistent. I find that it occurs most often after switching on the device. If I pause the playback and turn it off/on again, it seems to happen less often.
There are a few songs now where it skips at ~00:45 every time. I'm currently checking the integrity of those files.
When it skips, it usually skips at 45 seconds to 1 minute in and not every time at the same song. Sometimes this happens several times in a row (which prompts me to turn the Clip+ off/on again).
I've used the sansa stock firmware for file transfer because the previous rockbox versions didn't work with USB.

I cannot say if rockbox doesn't "load" any images or such - but the Clip+ isn't really a device with a screen made for image display ;)

Ok, your problem is "similar" than mine. I noticed that "some songs" skips often than others, and, generally, it skips or at stars, after :45 sec, or at the end… in my case, it's less often: in 1 hour session, it can happen 2/3 times or nothing at all, but it's very strange. Can you attach your config file, so I compare it with mine trying to understand if there's some options that cause this problem?

I've attached my config.

Sometimes it makes loud noise when skipping randomly too. This is quite irritating.

I was having this same issue on a sansa clip v2. I have since tried the sd card and files on two other sansa clip v2s running the same rock box versions. Though it was consistent even through rockbox reinstalls and a sd card switch on the defective player, I've had no issues on the other two. Therefore, while this bug may be possible to avoid by rockbox firmware in some way, it seems the underlying issue is in the hardware of the player itself. Figured I'd put this out there that the fix is probably to replace the player itself.

Mah… I think that it's simply a different hardware, but, as I seen, Rockbox community gives a fuck about these kind of problems, so I switch to mp3. It's a shame, but next time I'll inform better about Rockbox player, this time WELL SUPPORTED and reading possibly issues with lossless files.

This still happens to me on regular bases in FW 3.13, radom tracks, random duration. Sometimes after 20 seconds other tracks after 2-3 minutes.
Last time noticed it on 24bit 88Khz track.

I encounter this one too but I would still kiss the ground these devs walk on.


Anyone confirm if this still happens in the latest dev versions?


Available keyboard shortcuts


Task Details

Task Editing