Rockbox

Tasklist

FS#12222 - Rockbox does not detect headphones unplug

Attached to Project: Rockbox
Opened by SoulDeaD (souldead) - Tuesday, 09 August 2011, 06:01 GMT
Last edited by Frank Gevaerts (fg) - Thursday, 11 August 2011, 21:36 GMT
Task Type Bugs
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System iPod Nano
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I hadn't updated Rockbox for more than a year now and I used RockboxUtility to update it with current build r-30267(but the issue exists long ago). I did complete installation and it stopped detecting headphones unplug. I traced all releaces back to Rockbox 3.2 and the best I could get was Rockbox to detect headphone unplug once. Sometimes it would pause for a second and then resume. It also does not detect if headphones are unplugged at startup to avoid resumig playback.
This task depends upon

Closed by  Frank Gevaerts (fg)
Thursday, 11 August 2011, 21:36 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  Was a hardware issue
Comment by SoulDeaD (souldead) - Wednesday, 10 August 2011, 08:21 GMT
I tried older versions of Rockbox including the bootloader and it didn't seem to solve the problem.
I did a complete uninstall, and then used ipodpatcher to instal the old bootloader from version 2, then installed Rockbox version 2 and even that didn't help.
I still haven't tried to restore the iPod.

Can somebody give me any clues? What might help or where in the code should I eventually look?
Comment by Andree Buschmann (Buschel) - Wednesday, 10 August 2011, 13:11 GMT
look for headphones_inserted(void) in trunk/firmware/target/arm/ipod/button-clickwheel.c
Comment by Jonathan Gordon (jdgordon) - Thursday, 11 August 2011, 11:32 GMT
This sounds like a hardware issue. noone else has mentioned this and the same thing happened on my mini2g.
Go into Settings > Debug menu > View I/O ports, the top has A:<some value> plug in the headphone and wait a second or two, then unplug it. If that A: number doesnt change it means you have a harware issue and there is nothing we can do about it.
Comment by SoulDeaD (souldead) - Thursday, 11 August 2011, 12:12 GMT
Thanks a lot!
I opened the debug screen and saw the value didn't change... for a while... but then it flickered to something else. After some really slow and gentle unplugs the device managed to handle them but after that - nothing.
Taking in account that I opened the device up before updating it and that is sometimes really pause and sometimes it resumes immediately after pause - it's definitely a hardware issue. Maybe there's dust or something else.
I'll check it out this night and will update you
Comment by SoulDeaD (souldead) - Thursday, 11 August 2011, 21:29 GMT
It was definitely a hardware problem. I opened up the device and blew the dust and it works properly again.

Again, thanks for the clue, Jonathan and Andree!

This ticket can be closed.

Loading...