Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Bootloader
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by yzflcyq - 2011-09-24
Last edited by bertrik - 2011-09-28

FS#12290 - Rockbox can't boot on OndaVX747

Just now I knew that a commit fix a serious problem ( FS#12273 ) and I updated my source to r30593. I can’t get it booted, but booting old Rockbox is OK. When I pulled my power button and tried to boot, it just froze at the Bootloader Logo (If I use ROLO to load it before, it freezes at loding…). However, if I pulled power button again, it could reboot itself.

I tried my modified version and the original version of Rockbox. Neither of them can’t be booted.
The only commits between the OK version and the bad version are changing the font cache, so the problem is due to font cache using buflib I guess. It’s not PANIC, not crash. I think it just need some work before it can initialize the font cache.

Closed by  bertrik
2011-09-28 11:03
Reason for closing:  Fixed

Do you have an SVN revision number of the change that caused the breakage?

Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557

i have a similar issue on my clip+. i reported it in the forums here.. http://forums.rockbox.org/index.php/topic,28907.0.html

i too only tested 30593 but i see all commits from 30589-30593 look related so i went back to 30588 and that works fine.

@bertrik: I tested the version briefly and things go wrong since r30589. Now I will use r30589 based modified version for the time being, butI hope we can find out the reason quickly.

That’s solved when I updated to r30614. Thanks.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing