Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Recording
  • Assigned To No-one
  • Operating System Sansa AMSv1
  • Severity Low
  • Priority Very Low
  • Reported Version Release 3.9
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by SamoDadela - 2011-09-24
Last edited by speachy - 2020-07-14

FS#12291 - Sansa Clip+ CPU/LCD noise while recording

Recording noises on the Clip+

Probably a hardware problem though the original firmware somehow alleviates it.

When recording from:
1) Microphone

  Noise is heard at the beginning of the recording while the LCD is still on, when it turns off
  (goes to sleep) the noise goes away. Noise is then heard each time the CPU compresses
  or writes the data. This can be alleviated by changing the rec. frequency from 44k to 
  22k. The noise at the beginning can also be heard using the original Clip+ firmware, 
  however the compress/write noise is not there (or is very low) - probably because the
  original firmware writes at 22k (mono), too.

2) FM Radio

  When recording FM using RB the CPU interferes with the FM receiver. This results in 
  the normally clean reception being broken by noises of 1-2 second duration happening 
  every 4-5 seconds (this can be longer if there is FM transmits silence - guessing 
  because the buffer fills slowly).
  The original Sansa Clip+ firmware is also affected by this problem, however it is much
  less noticeable. There the interference is heard like very tiny clicks of the period of 0.5
  seconds - very silent but it is there.

As said its probably caused by the Clip+ not being shielded from interference (LCD, CPU
or something else) but the original firmware somehow works around the problem by not
working in bursts.

So… is it possible to process (record/encode/write) the audio in small pieces more
frequently instead of doing it in bulk each time the buffer fills? This could result in the
noise being less pronounced and thus not annoying. Maybe by making the buffers smaller?

Closed by  speachy
2020-07-14 15:43
Reason for closing:  Not a Bug
Additional comments about closing:  

This is fundamentally a hardware flaw that we can do nothing about. The Clip+ simply does not have properly shielded audio circuitry and at best all we can do is make the noise take less time, but it will occur more often as the same amount of data needs to be processed and written regardless.

More on the FM issue: it seems that the noise is dependent on the radio frequency we are tuned into - not much we can do here.
Checked again the CPU noise when recording from mic to exclude that the noise is induced only to the headphones - I can confirm the noise can be heard also on the recording.

Correction: Hardware should be AMSv2.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing