Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Drivers
  • Assigned To No-one
  • Operating System Sansa e200
  • Severity High
  • Priority Medium
  • Reported Version Daily build (which?)
  • Due in Version Next release
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Michael Chicoine - 2011-10-08
Last edited by Andree Buschmann - 2011-10-21

FS#12324 - e200v1 USB connection problems since r30701

I am having USB connection problems on my e200v1 since r30701: Add missing usb_drv_init(), fixes FS #12303

When connecting USB to win7 computer, a message is displayed that says the device should be connected to a USB 2.0 port (all ports are USB 2.0). The device takes a long time to mount (if it ever does) and will sporadically dismount/remount.

Reverting r30701 on current svn corrects the problem.

This problem is not present in r30700 or prior builds.

Closed by  Andree Buschmann
2011-10-21 11:17
Reason for closing:  Fixed
Additional comments about closing:  

Sloved with r30811.

Richard Brittain commented on 2011-10-16 21:42

Spurious USB 2.0 message also appears on my Vista PC, connecting both directly and to my Ubuntu VirtualBox build environment. (VirtualBox is set to always connect my Rockboxed e280v1 to the Ubuntu VM when running.) Long mount times occur in Vista directly, but not in Ubuntu. Also, the first several times trying to eject and/or safely remove in Vista fail because the drive is supposedly being used (though it’s not); after awhile it finally disconnects. (Again, this does *not* occur in Ubuntu.)

Will have to manually revert r30701 to see if it fixes my problems.

Richard Brittain commented on 2011-10-16 22:20

Reverting r30701 removes the spurious USB 2.0 messages. However, the long mount times & “safely remove” lockout still occur in Vista. Patch removing r30701 from current SVN (r30764) attached.

Andree Buschmann commented on 2011-10-19 16:29

Great :/ We need JhMikeS to check this again. r30701 was done to fix a non-working USB connection for iPod Video since r30546 and r30549.

I am not sure whether we should just encapsulate usb_drv_init() with “#if defined(IPODVIDEO)”… For the release this would be fine, but not as the final solution…

Richard Brittain commented on 2011-10-19 16:35

You might want to test other PP targets as well. All I can tell from this vs. the other patch is it’s necessary for iPod Video but causes problems with Sansa e200v1.

Andree Buschmann commented on 2011-10-19 16:39

I would really love to see a root cause analysis of the iPod Video’s issue since r30546. All we do now is adding patches…

Andree Buschmann commented on 2011-10-19 19:55

Richard, did I get you right that you also need the usb_drv_init() for your iPod Video?

Richard Brittain commented on 2011-10-19 20:10

No; like the OP, I have an e200v1 and need it taken out. I only mentioned the iPod Video because it’s what r30701 was created for; from that, it appears it needs to be left in for that one.

My main suggestion, however, was to test for PP targets *other than* e200v1 & iPod Video to determine if they need it left in (like the iPod Video) or taken out (like the e200v1).

Richard Brittain commented on 2011-10-19 20:12

Addition: Since AFAICT the usb-drv-arc.c file is for *all* ARM targets, perhaps testing on non-PP ARM targets is necessary as well…

Admin
Frank Gevaerts commented on 2011-10-19 20:23

It’s not that simple. My ipod video doesn’t need r30701 (but on the other hand it also doesn’t seem to have problems with it)

I don’t think we need more tests on various targets, we need to understand why Buschel’s ipod needs to be initialised twice.

Michael Sevakis commented on 2011-10-19 20:35

I would only have that hacky reset for the specific device that requires it (iPod Video), otherwise leave it out. Nothing else I had required it.

ETA: Yeah, like the second patch.

Michael Sevakis commented on 2011-10-19 20:37

@Frank: Ooh, interesting.

FWIW: iPod Video annoys me. That would be a second special hack just for it. I’ll bet the power setup is wrong.

Richard Brittain commented on 2011-10-19 20:55

If everyone’s agreed that the original issue was iPod Video-specific (maybe even Buschel-specific) and we don’t need that init on any other target, I’m fine with Buschel’s patch.

Andree Buschmann commented on 2011-10-20 05:18

If noone objects I will just submit the patch from abvove with some additional comment (see attached patch). This way svn becomes usable for the e200 (and maybe other PP’s) as well. We can then dig further into this issue with my iPod…

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing