• Status Closed
  • Percent Complete
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Release 3.9
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Terry The Great - 2011-11-19
Last edited by BigBambi - 2012-04-13

FS#12393 - Annoying "click" before track restarts

When the user manually skips back to the start of an MP3 (ID3v2.3) there is an annoying click before the same music track begins again (Obviously this occurs after a few seconds of play). First the songs stops, there is an small instant of silence, followed by a click, then another small instant of silence, then the song restarts. The original Sansa® Fuze™ firmware does not have this problem.

Player: Sansa® Fuze™
Rockbox Release: 3.9.1
Contact for details:

Suggestion: If this is not the proper way to submit a bug then give DETAILED INSTRUCTIONS on how to do it properly

Closed by  BigBambi
2012-04-13 19:13
Reason for closing:  Fixed
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

Fixed in current build (bc41926, 3rd April 2012)

MikeS commented on 2011-11-19 00:49

I haven’t heard anything like this or it would have annoyed the hell out of me enough to have fixed it. :-)

Post a link to the file that causes this problem.

Copied from the forums:

You asked me to post a link to a file (I assume it was supposed to be an mp3). However, I should have said that ANY mp3 (or wma for that matter) will cause this problem). Try this:

Play any mp3 (preferably something with loud rock music) using any theme on the Sansa Fuze v2 using the current Rockbox version. After 10 to 15 seconds, skip back to the beginning of the track. I get a click which is often loud but sometimes soft in volume. Every time I skip back I get this annoying “click”. Try this several times. You must play a short section of the track before skipping back to the start.

Another way to do this is to play 10 to 15 seconds of the track and then engage PAUSE then skip back to the beginning of the track. Try this several times. I always hear an annoying "click" even when the music is paused.

Obviously I am unaware of the proper procedure to communicate directly with someone who just gives me a handle (such as MichaelGiacomelli(saratoga)) without an email address. I invite anyone to instruct me in how to do this properly. My email address is

In the future, please reply directly to your bug report. Anyway, I can’t reproduce this problem with the current build. Can you be more specific about how to reproduce it? And provide a file that causes the problem?

This message is for MichaelGiacomelli (saratoga)

This is a reply to your request for more details about the unwanted noise heard when I restart an MP3 on my Sansa Fuze v2 ( FS#12393 ). I am using the tracker to add a comment and attach a file. If this message and/or attachment fails to get through (fails to show up on the tracker) I will return to sending my message through the forum (or whatever method works). At the moment I am putting a lot of effort (and time) into tracking down the circumstances under which the various Rockbox bugs occur. Poor communications is another problem I don’t need.

With the introduction of Rockbox version 3.10 I find that the ‘click’ has generally disappeared but it has been replaced by something that resembles the sound a microphone makes when it is suddenly turned off. Occasionally this can itself sound like a ‘click’. It depends on where on the track the Left Press is activated. While the MP3 playback exhibits this problem less frequently, the attached WMA file does this every time it is restarted after several seconds of play. This WMA file was produced on a friend’s Windows 7 machine using Windows Media Player 12 to rip the track from a CD. The metadata was downloaded by Windows Media Player 12 which inserted it into the WMA file. I find that it gives the same results when ripped from the same CD on my machine. I try to avoid non-Microsoft software to rip CDs because this can introduce more problems. In order to accommodate the tracker’s size limit for an attached file, it was cut down to 1 minute. However, the new file I am sending to you has the exact same behavior as the full-sized WMA file.

Note: Any music file I provide to the Rockbox team is for testing and evaluation purposes, not for public broadcast.

Is this still a problem?

Why the hell are you opening a new bug to reply to a comment on this one? Do not pollute the bug tracker with nonsense like this again.

Curiously I can reproduce this on Fuze v2, but only with the track attached to this bug report and not with any others that I tried. I don’t have any wma to try. I haven’t tried on any other targets. This was with 3.11.2.


Available keyboard shortcuts


Task Details

Task Editing