FS#124 - Sound distortion on Player (6000)

Attached to Project: Rockbox
Opened by Anonymous Submitter - Friday, 09 August 2002, 22:56 GMT
Last edited by Daniel Stenberg (bagder) - Wednesday, 28 August 2002, 12:22 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To Linus Nielsen Feltzing (linusnielsen)
Operating System
Severity Low
Priority Normal
Reported Version Version 3.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I downloaded player MOD file (for firmware greate then

After renaming old ARCHOS.MOD (6.07a), I renamed new
mod file to correct name.

Repowered on.

Boot Logo is distored. Not same as show in screen shot.
More likse a centered graphic with empty band in center
of display (horizontal).

Real issue: MP3 playback had a lot of popping (like
overdriving) sound.

A fast 'loud' song by Bad Religion (supersonic)was all
A quiet starting song by Wierd Al (The Saga Begins)
plays fine in the beginning, but when background music
increases popping returns.

Adjusted Volume, Bass, and Teble to 30%, 0db and 0db
respectively, no change in pops.

...Bruce Sherwood
This task depends upon

Closed by  Daniel Stenberg (bagder)
Wednesday, 28 August 2002, 12:22 GMT
Reason for closing:  Fixed
Additional comments about closing:  Logged In: YES

Fixed in 1.3
Comment by Anonymous Submitter - Monday, 12 August 2002, 23:10 GMT

I was able to get rid of the distortion by changing the Bass
setting to 0db from the default 7db. Left treble at 7db and the
volume is at 50%.

Eric Trondson-Clinger
Comment by Anonymous Submitter - Tuesday, 13 August 2002, 04:59 GMT

Same problem on 6000 (built-in 5.03). Adjusting bass and treble did not
eliminate problem. FYI, daily build 0508 did not exhibit problem, an
earlier build (sorry don't remember which) did exhibit the problem.
Sounds like digital aliasing noise.
Comment by Juan Jose Presa Rodal (huevo5050) - Tuesday, 13 August 2002, 16:11 GMT

I eliminate the pops setting: Bass -> 0db; Treble-> 11db;
Volume ->100%
Comment by Anonymous Submitter - Monday, 19 August 2002, 10:02 GMT

I have observed similar 'overdrive' distortions on my studio 20
player. It is strange that this does not always occur. Sometimes
a song will play fine and all of a sudden a lot of songs will go
into overdrive. A restart of the system often solves the problem

Comment by Anonymous Submitter - Saturday, 24 August 2002, 12:22 GMT

try boostaroo
it solves all problems of sound distorsion when using a poor
quality onboard amplifier
Comment by Anonymous Submitter - Saturday, 24 August 2002, 21:26 GMT

In my opinion, this is the same problem as problem 596796. I
have it on my studio 20. There is even distortion on the line
out with most of the tracks I have.
I use version 1.2
Until this problem is solved, the rockbox is unusable for me.
The original archos software does not have this problem (but
is a lot less user friendly.
Great work !!!

Boostaro or some other external device will never solve this

Comment by Linus Nielsen Feltzing (linusnielsen) - Saturday, 24 August 2002, 21:36 GMT

OK, everyone. I have made an attempt to fix this. The fix has been in CVS
for quite a while now. Please, please download the latest daily build and
see if the problem is gone.
Comment by Anonymous Submitter - Monday, 26 August 2002, 22:19 GMT

The problem seems to be solved for me in one of the lates
daily builds (Studio 20)

Thanks a lot !!!

Comment by Daniel Stenberg (bagder) - Wednesday, 28 August 2002, 12:22 GMT

Fixed in 1.3