Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface → Themes
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by StephenCarroll - 2011-11-27
Last edited by Buschel - 2011-12-19

FS#12411 - Album art not displaying correctly on iAudio x5, verk dark

Started the last few days. Very dark album art.
On version r31079-111127

Happens with embedded or with folder.jpg.
Using the picture viewer the art displays correctly, seems to be just in the WPS it looks dark.

Closed by  Buschel
2011-12-19 19:17
Reason for closing:  Fixed
Additional comments about closing:  

Fixed with r31366.

Admin
fg commented on 2011-11-27 19:53

I can reproduce this on my x5, haven't tried other players yet.

I'd say it's not exactly dark, rather wrong. Red and blue seem to be fine (or nearly so anyway), while white is shown as black.

The 3.10 branch doesn't have the problem

Admin
fg commented on 2011-11-27 20:02

gigabeat f doesn't have this. Maybe related to pixel format?

I'm attaching the file I use to test

Sorry about the quality all I had was my camera phone.
First two shots taken with r31089 then the cover in the image viewer and finally last two in the rc's of 3.10 showing the normal image.
Can also confirm the X5 Panics on screenshot so the only way I could get images was with my camera phone.

In apps/recorder/bmp.c there is some Coldfire specific assembler code. After reviewing r30938 I saw at least one line of code which might be wrong. The attached patch corrects this.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing