Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System Sansa Fuze+
  • Severity Low
  • Priority Very Low
  • Reported Version Release 3.9
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by JeanLouisBiasini - 2011-12-11
Last edited by JeanLouisBiasini - 2012-08-27

FS#12446 - [FUZE+]Undefined instruction at 0x0000AC44 when selecting an mp3 file while playing any other format

1. Way to reproduce:
While playing any file except mp3 select a MP3 file

2. Bug description
WPS stay idle a couple of second on the new file without playing it (detection of the format correctly being showed) then:

Undefined instruction at 0000AC44
backtrace start
pc: 0x0000AC44
sp: 0×00005350 backtrace end

find_addr.pl returns:
jean-louis@debian:~/Bureau/rockbox-devtree/rockbox/buidl$ ../utils/analysis/find_addr.pl 0x0000AC44 1
/home/jean-louis/Bureau/rockbox-devtree/rockbox/buidl/firmware/libfirmware.a(thread.o) → threads

jean-louis@debian:~/Bureau/rockbox-devtree/rockbox/buidl$ ../utils/analysis/find_addr.pl 0×00005350 1
/home/jean-louis/Bureau/rockbox-devtree/rockbox/buidl/apps/codec_thread.o →

Whatever the format of the “coming from” file is, the address in backtrace stay the same.

3. No bug if:
- If the files are in the same playlist, the bug doesn’t occurs - only on moving to a new dynamic playlist.

4. test performed:
tested format:
WMA > MP3 bug
MPC > MP3 bug
OGG > MP3 bug
FLAC > MP3 bug

MP3 > OGG no bug
WMA > OGG no bug
FLAC > OGG no bug

each format transition tested 2 times with 4 different files

Closed by  JeanLouisBiasini
2012-08-27 13:37
Reason for closing:  Fixed
Additional comments about closing:  

by 08/27/2012 the bug cannot be reproduced anymore Solving probably related to 4908b8e where pamaury fixed some dma issue

ogg > flac no bug
flac > wma no bug

I forget to write that if one stop the music (not pause, real stop) before selecting mp3, then the problem won’t occurs

rarog commented on 2011-12-20 01:05

I can’t reproduce this with current builds with flach > mp3 change.

rarog commented on 2011-12-20 01:11

Ok, I could reproduce this in 1 of 10 times. It seems to be unrelated to the files.

this is systematic on my device. What ever the file of whatever other format. But only if selecting it (i. e. generating a new dynamic playlist) and not just adding it to queue

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing