Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 FS#12448 : Data abort when trying to play a specific ogg-vorbis-file on my clip+

Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System Sansa AMSv2
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by rasferret - 2011-12-12
Last edited by nls - 2011-12-21

FS#12448 - Data abort when trying to play a specific ogg-vorbis-file on my clip+

When I try to play the ogg-vorbis file available at the following link,

http://alternativlos.cdn.as250.net/alternativlos-21.ogg

the player locks up with the following data abort:

svn-r31158:
Data abort at 30813c08
FSR 0×8 (domain 0, fault 8)
address 0x5643420D

svn-r31216:
Data abort at 30813c08
FSR 0×8 (domain 0, fault 8)
address 0x5643420D

The player doesn’t reboot after pressing a button. I have to turn it off by selecting the power button for some time.

Closed by  nls
2011-12-21 15:47
Reason for closing:  Fixed
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

Fix committed

Reproducible in sim as well.

tkwm commented on 2011-12-13 12:08

I have the same error with the same file on the Sansa Clip v2 and rockbox 3.10 and also 3.1212 (yesterdays last buid).
The file is being played when I boot into the Sandisk-firmware.
I've made a manual installation of rockbox 3.9.1 and the file is being played correct.

Removing the attached PNG album art (which is quite small) fixes the problem for me. Perhaps the metadata parser is choking on the tag.

tkwm commented on 2011-12-13 18:04

Is this an error in the ogg-file / the PNG OR in rochbox?

tkwm commented on 2011-12-13 23:37
Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557

The mentioned file alternativlos21.ogg does not contain a PNG or any other coverart or graphic.
None of the Mac-programs vlc, Traktor or Max display any coverart.
But the file contains a tag "METADATA_BLOCK_PICTURE" with a 40k content of, so I think, garbage.
On the Mac I was able to remove the tag with the program "Tag" (sic!) from sbooth. http://sbooth.org/Tag/ But, even with the erroneous tag the file is being played by rockbox 3.9.1 and it should not crash rockbox 3.10!

It sure contains a png-file as cover art. You can extract it by using mp3tag on windows. I've attached the cover art.

and the cover art crashes rockbox… :-(

I have the same issue. Any OGG file w/ embedded album art crashes the latest build on my clip+ and on the sim.

tkwm commented on 2011-12-14 08:56

I expected this graphic, but because none of the programs I use on the Mac displayed it, I thought there would be no.

Does anybody know a program for the Mac that is able to extract the graphic?

Tag can only delete the entry, but can not extract the content to a graphics-file and audioacity extracts it texti-coded only.

there seems to be some problem with the picture parser.
Jpg and png crashes, bmp not

nls commented on 2011-12-14 18:17

The embedded art in ogg vorbis files is not parsed by rockbox, the data is just thrown away by the codec. I hacked around a huge allocation in the codec if the cover art is very large but 40k should not be a problem, could you test if it's r30728 that breaks it?

Rolling back apps/codecs/libtremor to r30727 helps.

The bmp I've embedded into the ogg-file is about 200k large and the file does work.

nls commented on 2011-12-17 12:59

This should help

This should help
It does.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing