Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Drivers
  • Assigned To No-one
  • Operating System Another
  • Severity Low
  • Priority Very Low
  • Reported Version Release 3.9
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by jkbuha - 2011-12-17
Last edited by saratoga - 2016-09-08

FS#12460 - iPod Classic/6G crashes on USB connect (builds 31006 and above)

System: iPod6G - 160GB HDD
EMCORE: 708-828 vanilla build
Rockbox build: 31006+

Hi all

Ever since build 31006 I have been unable to connect my classic via USB to Linux/Windows. Upon insertion of the USB cord the device attempts to switch to USB mode, but either hangs or displays a ‘Data Abort’ kernel panic. I’ve traced the issue to be most likely due to the changes in buflib.c, as this is the only real significant commit between 31004 and 31006, but I may be mistaken.

Thanks
jkbuha

Closed by  saratoga
2016-09-08 19:28
Reason for closing:  Out of Date
Additional comments about closing:  

Should be fixed by the new USB stack.

I am not able to reproduce the panics, just the hangs. Can you provide the exact panic message and the exact revision number (or, even better, its .elf file)?

I’ve attached the elf file from the latest commit. All elfs built from 31006 upwards have the same effect.
I’m back on 31004 for stability so cannot give you the exact panic message, as I cannot boot a failsafe rockbox image from emcore 828, so I would need to reflash emcore with 708 in order to boot the failsafe rockbox image. Unless I’ve missed some way of building a failsafe rockbox image into v828?

Let me know if you need anything else from my end.

Cheers
jkbuha

nls commented on 2011-12-20 18:24

To test a different version of rockbox you can just put the rockbox.ipod (?) on the ipod and rolo it once your regular build has started
Also the attachment seems to have failed.

I have the rockbox.ipod file - how do I rolo(?) it?
I’ve tried to attach the file again - let me know if this works!

Doesn’t work on firefox or chrome - i’ve tried attaching a tarred gz version instead

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing