Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Drivers
  • Assigned To No-one
  • Operating System Sansa AMSv2
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Marc Hewson - 2011-12-18
Last edited by MichaelGiacomelli - 2016-08-28

FS#12461 - sansa clip+: usb does not work at all.

i noticed USB was enabled in r31226 and a lot of AMSv2 updates were made in the following days. i tried quite a few of these builds and none worked. i thought i’d leave it a few more days before reporting it here. i’ve just tried again with the current build (r31350 at time of me posting) and no joy.

the player shows the USB screen as i would expect but windows (7 x64) won’t recognise it properly. checking device manager i see “usb mass storage device” with a yellow exclamation mark and the following message in the properties…

This device cannot start. (Code 10)

i’ve tried connecting/disconnecting multiple times with and without a microSDHC inserted. the player gets locked on the USB screen and i have to do a long power off to reset it.

looking in the debug menu, it says my player is an AMS variant 1.

Closed by  MichaelGiacomelli
2016-08-28 20:12
Reason for closing:  Not a Bug
Additional comments about closing:  

Closing bug reports for the old USB stack now that we have the new one committed and stable. Most likely these problems are fixed now.

Marc Hewson commented on 2011-12-20 08:37

i’ve just updated to 31373 and usb is alive!! i just connected-disconnected several times and transferred some files with no problems at all.

…and just as i’m typing this out, i’ve disconnected once more and i’ve got a panic on the screen. hopefully just a one off..

*PANIC*
audio_reset_buffer_
malloc(): EOM (598
812 > 196708)

thanks for all your efforts guys.

Marc Hewson commented on 2011-12-21 22:44

i’ve done a lot more testing and connecting/disconnecting has been fine.

but i’ve just been copying several GBs worth of files to my microSDHC and windows came up with an error about half way through saying the destination was unavailable. both the internal and external memory had gone from explorer. when i unplugged, the player was locked on the USB screen and i had to do a long power off -but it was recognised instantly when i plugged it back it.

Daniel Kalle commented on 2011-12-22 15:28

Fuze2 variant 0
r31403

Connecting to a Linux 3.1.5 box I get most of the time the following error and the kernel ring buffer outputs “BUG: unable to handle kernel NULL pointer dereference at 0000000000000008” (the full dmesg report is attached):

Data abort
at 3002CA74 3002CB00
FSR 0×8 (domain 0, fault 8)
address 0x8F595CE4 0x619DC050

If the connection was successful it hangs after disconnect (doesn’t go back to main menu and the status bar clock stops).
A few times I also got the following PANIC:

*PANIC*
audio_reset_buffer_malloc(): EOM (598800 > 196708)

The bootloader usb support has no problems (Test procedure: rename .rockbox folder in rockbox, reboot and connect to the computer).

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing