Rockbox

Tasklist

FS#12465 - dont connect to USB turned on MPIO HD300

Attached to Project: Rockbox
Opened by Andrew (azariev) - Sunday, 18 December 2011, 13:19 GMT
Last edited by Andree Buschmann (Buschel) - Monday, 19 December 2011, 18:17 GMT
Task Type Bugs
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

r31231and r31235
- if you connect a USB turned on player - that player hangs - only helps to reset, but if connected to a USB turned off player - everything is fine
But at r29604 (the latest build of which I have long used) have not that problem
This task depends upon

Closed by  Andree Buschmann (Buschel)
Monday, 19 December 2011, 18:17 GMT
Reason for closing:  Fixed
Comment by Marcin Bukat (MarcinBukat) - Sunday, 18 December 2011, 19:11 GMT
I tried with r31235 (actually the same build I prepared for You) and I can't reproduce the problem. USB works as expected.
Comment by Andrew (azariev) - Monday, 19 December 2011, 06:23 GMT
I repeat:
if the player off and then connected to the USB - it's OK
if the player is turned on and then connected to the USB - player hangs and does not respond, the same way as it does not appear in Windows Explorer as a removable drive.
I tried several times to both r31231and r31235 and different USB ports of my notebook. In the evening I'll try to make a video about it.

PS OS - windows XP SP3 (cracked)
Comment by Andrew (azariev) - Monday, 19 December 2011, 16:09 GMT
sorry for poor video from my phone :(
the problems described above were confirmed
but fix r31325 mods by Marcin BuKat (19-122011) eliminate them
Comment by Andrew (azariev) - Monday, 19 December 2011, 16:26 GMT
and r31365 works with USB properly
tMany thanks to Marcin Bukat and Thomas Martitz!

Loading...