FS#12466 - battery charging problem at MPIO HD300

Attached to Project: Rockbox
Opened by Andrew (azariev) - Sunday, 18 December 2011, 13:23 GMT
Last edited by Marcin Bukat (MarcinBukat) - Saturday, 24 December 2011, 09:45 GMT
Task Type Bugs
Category Battery/Charging
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


r31231and r31235
After a complete discharge of the battery, when you plug the charger, the battery does not reach 4.2V, the charge stops in about 4,05-4,1V
If you disconnect the charger and reconnect after that, the charge continues and reaches 4.2 V
(wiki info: cutoff voltage is 4.23 V (fully charged))
May have restrictions on the duration of the charge? I have installed high-capacity battery, and I exhibited in the menu settings of its capacity (config.cfg - > battery capacity: 1800 is also present)

But at r29604 (the latest build of which I have long used) have not that problem
This task depends upon

Closed by  Marcin Bukat (MarcinBukat)
Saturday, 24 December 2011, 09:45 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed
Comment by Andrew (azariev) - Tuesday, 20 December 2011, 04:25 GMT
r31325 mods by Marcin BuKat (19-12-2011) removed and that problem. Now, when you charge the battery voltage reaches 4.2v
attachment is only for r31235

More newest builds I have not tried to work with the test battery.

Many thx 2 Marcin BuKat