FS#12470 - Rename "mp3entry.embed_albumart" to "mp3entry.has_embedded_albumart"

Attached to Project: Rockbox
Opened by Alexander Levin (fml2) - Tuesday, 20 December 2011, 21:50 GMT
Last edited by Alexander Levin (fml2) - Thursday, 22 December 2011, 18:54 GMT
Task Type Patches
Category ID3 / meta data
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Release 3.9
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


The patch does just what the title says (and nothing else). I think the new name more clearly states what the field means. I hope I catched all occurences.

In a separate patch I'll probably rename the field "mp3entry.embed_cuesheet" to "mp3entry.embedded_cuesheet".
This task depends upon

Closed by  Alexander Levin (fml2)
Thursday, 22 December 2011, 18:54 GMT
Reason for closing:  Accepted
Additional comments about closing:  Committed as r31405
Comment by Nick Peskett (nickp) - Wednesday, 21 December 2011, 06:05 GMT
Excellent patch, I've no excuse now ;)
Comment by Thomas Martitz (kugel.) - Wednesday, 21 December 2011, 07:11 GMT
Just nit-picking, but how about moving the bool into the struct as done with cuesheet ("bool present;")?
Comment by Alexander Levin (fml2) - Wednesday, 21 December 2011, 10:15 GMT
This is not nit picking, it's a matter of style. I've seen that difference. In the planned cuesheet patch I'd move the boolean field out of the structure, i.e. make it like album art. I like it more that way, i.e. have a separate field telling whether the structure can be used, and not making the field part of the structure itself.

But that would be part of a separate patch.