FS#12480 - disktidy: Sansa AMS MUSIC/ directory

Attached to Project: Rockbox
Opened by Hunter Ragnarok (G4Oblivion) - Saturday, 24 December 2011, 12:09 GMT
Last edited by Alex Parker (BigBambi) - Saturday, 24 December 2011, 23:50 GMT
Task Type Bugs
Category Plugins
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I noticed that r31238 added the option of "cleaning" the MUSIC directory under "Sansa AMS".
I do not believe that this should be an option for the following reasons:

1.) Although this directory is created automatically by the OF, the user could have easily created it themselves.
2.) "MUSIC" is a very common directory name; I use it for all my players.
3.) The OF uses the "MUSIC" directory to store your audio files, which are hardly "junk files". This doesn't make sense for users that use both the OF and rockbox.

Basically, it makes no sense to have this as an option. If the user want it they can add it to the disktidy config.

This was an unwelcomed surprise for me when I selected "ALL" like I usually do and find out all my audio files were deleted.
This task depends upon

Closed by  Alex Parker (BigBambi)
Saturday, 24 December 2011, 23:50 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  Please bring it up on the developers mailing list.
Comment by Dominik Riebeling (bluebrother) - Saturday, 24 December 2011, 14:45 GMT
I'm not sure if this really belongs here -- it's not really a bug. The change is intentional and works as expected. And while I agree with your reasoning I think this should better be discussed on IRC / the mailing list instead of having it in the tracker.

It also might make sense to extend disktidy to allow hiding folders during the cleanup process, so a folder MUSIC can just get the hidden flag set in this case instead of removing it.
Comment by Thomas Martitz (kugel.) - Saturday, 24 December 2011, 16:03 GMT
Isn't the commit about ##MUSIC# rather than MUSIC?
Comment by Hunter Ragnarok (G4Oblivion) - Saturday, 24 December 2011, 20:38 GMT
I'm sorry, I wasn't sure where I should post this. I completely forgot about the mailing list.
IMO, just because a file/directory is automatically created by the OF, doesn't mean that it's a "junk file".
While the directory may be automatically created again, the contents of the directory are not. If the contents were just "junk files" then it would make sense to delete them, but the files are created by the user (e.g: MUSIC, AUDIOBOOKS, PODCASTS, etc.)

Both ##MUSIC# and MUSIC directories are options to be cleaned under < Sansa AMS > in disktidy. In this case I'm talking about the MUSIC directory.

Again, I'm very sorry for creating a flyspray about this. I should have placed it in the mailing list.
Comment by Alex Parker (BigBambi) - Saturday, 24 December 2011, 23:50 GMT
For the record, I agree with you - "Music" shouldn't be there. Having said that it isn't a bug as such as it is intended. I'll close it here, please bring it up on the -dev mailing list.