Rockbox

Tasklist

FS#12501 - stereo width - not working as documented - 3.10 - Sansa Fuze v1

Attached to Project: Rockbox
Opened by ed (returno) - Saturday, 31 December 2011, 20:14 GMT
Last edited by MichaelGiacomelli (saratoga) - Tuesday, 03 January 2012, 23:04 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System Sansa Fuze+
Severity Low
Priority Normal
Reported Version Release 3.10
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I have a Sanza Fuze V1. I'm using 3.10.

I made a stereo recording that has sound only on the left channel - this verified in Audacity. There is zero sound on the right. (Why I won't go into, but it is part of a larger project where some part of the recording with be on either the left or right or both)

I want to hear the recording such that there is only sound on my left-hand earbud. I go to "channel configuration" and choose "custom". Then, I go to "stereo width". Here is where things seem to not be working according to the documentation. I was expecting this:

0% = mono, equal volume on both ear buds
100% = same as "stereo" setting - a little sound in the right earbud, left has normal sound
250% = no sound on the right earbud, left has normal sound

What I hear is:

0% = mono
95% = a tiny amount of sound on the right ear bud
100% = same as "stereo" - a bit of sound on the right ear bud - more than at 95%
...going up = more and more sound on the right earbud (???)
250% = about the same as 0% (???)

There is no setting where there is zero sound on the right earbud, which is necessary for my project to work correctly, unfortunately.
This task depends upon

Closed by  MichaelGiacomelli (saratoga)
Tuesday, 03 January 2012, 23:04 GMT
Reason for closing:  Not a Bug
Comment by Andree Buschmann (Buschel) - Tuesday, 03 January 2012, 09:45 GMT
The behaviour is correct -- except the small amount of signal on the right ear-plug when setting stereo width to 100%. This is not caused by the stereo width setting (I just checked the maths) but by either some other sound processing or any electrical issue.

Why the behaviour is correct: The stereo width setting mixes L and R input signals to L and R output signals. Only 100% keeps the "pure" L/R untouched. Settings below 100% will result in mixing L signal parts into the R channel (and vice versa), settings above 100% will result in mixing *inverted* L signal parts into the R channel (and vice versa). Mixing together L and R w/o inversion will reduce the stereo image, mixing with inversion will widen the stereo image.

As you play with a signal which only has L signal, all settings above or below 100% will result in raising signal on the R channel.

I will close this bu report in a few days.

Loading...