Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface
  • Assigned To No-one
  • Operating System iPod Nano 2G
  • Severity Low
  • Priority Very Low
  • Reported Version Release 3.10
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by lain - 2012-01-21
Last edited by speachy - 2024-04-22

FS#12556 - hardware buttons doesn't work after using Hold on iPod

Hello!
Not very long ago I got iPod Nano 2 gen 8gb, installed rockbox and encountered this strange behavior:

After pushing and releasing Hold button player doesn’t react on wheel. When I’m trying to use some other button(Menu, for example), nothing happens. After third attempt to use a button Rockbox does button context properly, showing me what I wanted to see a few clicks ago. What happens with interface after using Hold? When I return to ‘Now playing’ screen throughout Menu, all works fine. But right after using Hold button I can’t nor increase/decrease volume, neither move in a menu list.

Closed by  speachy
2024-04-22 22:06
Reason for closing:  Invalid
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

This is … 12 years out of date, but I'm personally unable to reproduce this on the nano2g I own.

What version of rb are you using? Does this occures with other rb version (previous, current)?

lain commented on 2012-02-16 21:12

I use 3.10 version, haven't tried other versions yet. I found a similar bug here dated 2006, someone posted a little patch there. But that seemed to me as resolved.
Do you advice me to try any other versions of RockBox? Are there any problems in downgrading/upgrading versions? I'm quite nervous to do it after updating my motherboard's bios.

Can't reproduce the issue on my nano2g, sorry. I tried a few different builds without problems.

lain commented on 2012-02-17 04:24

I have 8 gb model, maybe that matters?

Unlikely. Anyway you may try to attract TheSeven's attention on IRC - he is kind of maintainer of nano2g port.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing