FS#12557 - Archos Recorder 1.0: Rockbox 3.10 + Daily Builds: File Too Big for Chip Error

Attached to Project: Rockbox
Opened by Lorenz (lorenzv) - Sunday, 22 January 2012, 04:38 GMT
Last edited by Boris Gjenero (dreamlayers) - Sunday, 05 February 2012, 16:34 GMT
Task Type Bugs
Category Bootloader
Status Closed
Assigned To No-one
Operating System Archos Recorder
Severity Low
Priority Normal
Reported Version Release 3.10
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I am a long-term Rockbox user on my Archos Recorder 1.0. I have been using Rockbox 3.9.1 and today wanted to try the latest daily build. After loading the ROLO just fine, when then trying to flash the boot-loader to the latest rockbox.ucl, I always get the error:

File too big
won´t fit in chip.

Any key to exit

Now I though this might just be a problem of the daily build that got to big because it´s not yet optimized for a release. However, I´ve checked out 3.10 official release afterwards and the exact same problem appears. The latest one that flashes the rockbox.ucl just fine for me is 3.9.1.

Is the support for the Archos Recorder 1.0 over and is noone testing these builds anymore and hence I am the first one noticing that Rockbox bootloader become to big for the Archos Recorder 1.0 chip?

Thank you.
This task depends upon

Closed by  Boris Gjenero (dreamlayers)
Sunday, 05 February 2012, 16:34 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  The problem was an old bootloader. 4b85c93 improves rockbox_flash messages so the user is notified that the bootloader needs to be updated.
Comment by Boris Gjenero (dreamlayers) - Sunday, 22 January 2012, 06:37 GMT
If you have the v3 bootloader at and your flash chip size is 256k, there ought to be enough space. The v2 bootloader at should be fine too. Both start the second image at 0x7000 offset in the chip. The v3 has bootloader has bugs (FS#12426), but the v1 recorder is not very affected.

I suspect you have an old bootloader which uses more space at the start of the chip. If you're wondering what you have installed or want a backup before flashing a new bootloader, you can dump flash to a file via the debug menu.

I successfully flashed a current build after 3.10 onto my Recorder v2.
Comment by Lorenz (lorenzv) - Sunday, 22 January 2012, 06:50 GMT
Hi Boris,

thanks for your reply. I don´t exactly understand, I have the Archos Recorder V1 and always used this Rockbox version:

I don´t have Archos Recorder V2, nor V3. So how could I flash the bootloader of V2 or V3 to a V1 recorder? Won´t that destroy the functionality and I won´t be able to boot anymore?

The informations under "Debug" currently say:

Rom: 1.28
Mask: 0x0302
Flash: M=BF D=D6
Boot Rom: V1

I can flash (and re-flash over and over) the rockbox.ucl of version 3.9.1 for archos recorder ( with a size of: 186.809 bytes

In the the rockbox.ucl is 195.166 bytes and regardless how often I try, it always says it´s to big for my chip:/

So you say I should flash the bootloader of V2 or V3 to my Archos Recorder V1? Are you sure that my device will not be unuseable after doing such a wrong flash?
Comment by Lorenz (lorenzv) - Sunday, 22 January 2012, 06:52 GMT
P.S.: My bootloader is of version 3.9.1, that flashes absolutely fine, also over and over again. If I turn on the device it directly says "3.9.1" without the need to load the ajbrec.ajz afterwards. So my bootloader is V1 and from the 3.9.1 release. Just from 3.10 and up it´s to big for my Archos Recorder V1:/
Comment by Boris Gjenero (dreamlayers) - Sunday, 22 January 2012, 15:36 GMT
When I was talking about v2 and v3 bootloaders, I was talking about bootloader versions, not Recorder versions. They are both for the Archos Recorder V1. (The bootloaders for the Recorder V2 are named and

The bootloader is software which runs first. It unpacks rockbox.ucl into memory and then transfers control to it. It also has a stripped down copy of Rockbox which you can use for recovery. This takes up some space in the chip, and only the remainder of the chip is available for rockbox.ucl.

You need to first flash the bootloader via firmware_flash, and then you should be able to successfully flash rockbox.ucl. The manual has information on flashing:
Comment by Lorenz (lorenzv) - Sunday, 22 January 2012, 16:19 GMT
Hi Boris,

oh I understand now! I thought the rockbox.ucl is actually always the complete firmware. I didn´t know that there is even another one underlying it. So I´ve flashed V3 for my Archos Recorder, then loaded the newest daily build and the rockbox.ucl now flashes fine and the device is running the latest version now:) You are the man, thanks for your help, everything perfect again:)

Keep up the good work and have a nice weekend:)
Comment by Lorenz (lorenzv) - Sunday, 22 January 2012, 16:36 GMT
Hmm, I am not sure what happened now, but after restarting my archos a second time, I now get

I 4: IllInstr

directly at booting. I then press "On" again and get:

Stkov main

And the HD shuts down. If I press "On" again, the same loop continues. What do I need to do now? :/

Comment by Lorenz (lorenzv) - Sunday, 22 January 2012, 16:39 GMT
OK, seems this was because I loaded my old "config.cfg" from 3.9.1 with my previous settings and something has changed in 3.10 and up. I did plug it to USB, removed the rockbox directory and copied it again from the newest daily build, then restarted. It boots up fine again now. So it seems I have to do the old settings again manually, but that´s not a problem. All fine again and hope this post helps someone else.
Comment by Boris Gjenero (dreamlayers) - Sunday, 22 January 2012, 18:16 GMT
It's good to know that you were able to get everything working.

Perhaps this should be added to the manual. I'm attaching a patch.

An out of date config.cfg should not crash Rockbox, so that crash seems to be a bug. If you still have your old config.cfg, please post it. You can create a new bug report about the crash and attach it there.
Comment by Lorenz (lorenzv) - Sunday, 22 January 2012, 20:12 GMT
OK great, I will submit a new bug report, I still have the config. Thanks again for your work, it´s much appreciated!
Comment by Boris Gjenero (dreamlayers) - Monday, 23 January 2012, 23:40 GMT
When you flashed rockbox.ucl while you still had the old bootloader, did you get a message like this:
Hint: You're not
using the latest
A full reflash is
recommended, but
not required.

There is a version check in rockbox_flash, based the byte at offset 0xFA in the flash. The byte is correct in v2 and v3 bootloaders. There doesn't seem to be any automated way of setting it. It must have been set by patching the template file supplied to make_firmware, or by patching the firmware file.
Comment by Lorenz (lorenzv) - Tuesday, 24 January 2012, 00:48 GMT
Yes, I did indeed get this warning, but from the words in it I understood it the way that the firmware currently on my archos is not the latest and I should flash this one. So basically I understood: the rockbox.ucl on the archos in the flash is not the latest one and that this one i am now flashing is the latest one and hence I should flash it. I thought flashing rockbox.ucl = a full reflash. Maybe the wording should be more clear since I never knew that the bootloader is something extra, aways thought bootloader = rockbox.ucl.
Comment by Boris Gjenero (dreamlayers) - Friday, 27 January 2012, 06:43 GMT
I think improving the diagnostic output is better than a note in the manual. Here's my patch.