Rockbox

Tasklist

FS#12571 - Save pitch/speed settings

Attached to Project: Rockbox
Opened by Tim Chase (Gumnos) - Monday, 30 January 2012, 14:19 GMT
Last edited by Thomas Martitz (kugel.) - Monday, 30 January 2012, 23:03 GMT
Task Type Bugs
Category Settings
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Release 3.10
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Though documented, Rockbox doesn't currently save the pitch/speed settings over a power-cycle. This means that every time I pause it and it automatically shuts off, I have to jump through the hoops of cranking it back up to 200% playback speed. This should be saved across power-cycling.
This task depends upon

Closed by  Thomas Martitz (kugel.)
Monday, 30 January 2012, 23:03 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  You posted the relevant text yourself. This is not a bug since it's excepted and documented behavior. If you want it changed please prepare a patch and get it discussed.
Comment by Tim Chase (Gumnos) - Monday, 30 January 2012, 14:20 GMT
FWIW, this was on a Sansa Clip+, but based on the documentation, I believe it touches all platforms.
Comment by Tim Chase (Gumnos) - Monday, 30 January 2012, 19:33 GMT
Relevant documentation: """
The value of the rate, pitch and speed is not persistent, i.e. after the
player is turned on it will always be set to 100%. However, the rate, pitch
and speed information will be stored in any bookmarks you may create (see
section 8.6 (page 66)) and will be restored upon playing back those
bookmarks.
"""

Loading...