FS#12576 - wma files with cover_art picture are not read on Sansa Clip

Attached to Project: Rockbox
Opened by Ch P (zoug_69) - Friday, 03 February 2012, 15:02 GMT
Task Type Bugs
Category ID3 / meta data
Status Unconfirmed
Assigned To No-one
Operating System Another
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No


Player = Sansa ClipZip
Rockbox current build :
Target: sansaclipzip
Target id: 68
Target define: -DSANSA_CLIPZIP
Memory: 8
CPU: arm
Manufacturer: as3525
Version: 7d54ff0-120203
Binary: rockbox.sansa
Binary size: 595788
Actual size: 595780
RAM usage: 922040
Features: alarm:backlight_brightness:crossfade:dircache:flash_storage:lcd_bitmap:lcd_non-mono:lcd_color:pitchscreen:multivolume:multidrive_usb:quickscreen:radio:recording:recording_swcodec:recording_mic:rtc:swcodec:tagcache:tc_ramcache:charging:large_plugin_buffer:ab_repeat_buttons:albumart:usb_power:usbstack
gcc: arm-elf-eabi-gcc (GCC) 4.4.4
ld: GNU ar (GNU Binutils)
Host gcc: gcc (GCC) 4.4.4 20100630 (Red Hat 4.4.4-10)
Host system: Linux
I cannot read .wma files with cover_art jpg.
The same file on the Sansa ClipZip as MSC storage is read correctly by plenty of players on my Ubuntu-PC : totem, VLC, mplayer ...etc...
I join a file as example (with and without cover_art jpg).
This task depends upon

Comment by Ch P (zoug_69) - Friday, 03 February 2012, 15:05 GMT
add attached files
Comment by Ch P (zoug_69) - Friday, 03 February 2012, 15:14 GMT
The same file with cover_art jpg is read correctly in the original firmware of Sansa ClipZip, and the image is displayed during the play…
Comment by Rasmus (rasmus) - Saturday, 11 February 2012, 12:12 GMT
This seems to be true for my misbehaving WMAs as well.
Comment by Luis (lagonauta) - Friday, 01 March 2013, 23:40 GMT
I can confirm that this is also happening with build e0d94f5-130222, all my WMA files with cover art do not play.