Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Operating System/Drivers
  • Assigned To No-one
  • Operating System iPod 5G
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Teun Kloosterman - 2012-02-10
Last edited by MichaelGiacomelli - 2012-04-17

FS#12583 - Rockbox stalls my computer's BIOS

A PC computer won’t boot with Rockbox plugged in.

My BIOSes (Award/Phoenix tried multiple) have USB disc and keyboard support enabled and my iPod Video/5G has Rockbox (tried multiple versions, now: 4d72c1b-120209) has USB disc and HID (mouse / presentation) enabled.

This causes all the computers I’ve tried to stall indefinitely while booting, usually right after the CPU/RAM check before the ATA summary, and immediately continues when I unplug the iPod like nothing happened.
This is very reproducible on, for instance, a Gigabyte GA-K8NS Pro, Panasonic CF-51 laptop, HP/Compaq PC’s and Dell Precision PC’s.

My guess is there’s a small problem with the virtual USB hub inside Rockbox that causes problems with a BIOS trying to recognize bootable media or input methods.

Closed by  MichaelGiacomelli
2012-04-17 17:01
Reason for closing:  Rejected
Additional comments about closing:  

This is probably not something that can be fixed from the Rockbox USB driver (short of removing USB HID), so there is not much point in leaving this open.

Admin
Frank Gevaerts commented on 2012-02-10 13:49

Have you tried with HID disabled?

There’s no such thing as a virtual USB hub inside rockbox, so that’s not where the problem is.

Teun Kloosterman commented on 2012-02-10 15:39

No, without HID there’s no problem.

But there are multiple device classes on one bus right? HID and mass storage
dmesg:

[10673.768038] usb 1-2: new high speed USB device using ehci_hcd and address 9
[10674.040215] scsi7 : usb-storage 1-2:1.0
[10674.075785] generic-usb: probe of 0003:05AC:1209.0003 failed with error -71
[10674.075923] usb 1-2: USB disconnect, address 9
[10674.348097] usb 1-2: new high speed USB device using ehci_hcd and address 10
[10674.497892] scsi8 : usb-storage 1-2:1.0
[10674.504910] input: Rockbox.org Rockbox media player as /devices/pci0000:00/0000:00:1d.7/usb1/1-2/1-2:1.1/input/input9
[10674.505133] generic-usb 0003:05AC:1209.0004: input,hidraw0: USB HID v1.10 Keyboard [Rockbox.org Rockbox media player] on usb-0000:00:1d.7-2/input1
[10675.498639] scsi 8:0:0:0: Direct-Access TOSHIBA MK3008GAL BU11 PQ: 0 ANSI: 4
[10675.506454] sd 8:0:0:0: Attached scsi generic sg2 type 0
[10675.508722] sd 8:0:0:0: [sdb] 14651280 2048-byte logical blocks: (30.0 GB/27.9 GiB)
[10675.510966] sd 8:0:0:0: [sdb] Write Protect is off
[10675.510976] sd 8:0:0:0: [sdb] Mode Sense: 0b 00 00 08
[10675.510983] sd 8:0:0:0: [sdb] Assuming drive cache: write through
[10675.525578] sd 8:0:0:0: [sdb] 14651280 2048-byte logical blocks: (30.0 GB/27.9 GiB)
[10675.528247] sd 8:0:0:0: [sdb] Assuming drive cache: write through
[10675.530401] sdb: sdb1 sdb2
[10675.535712] sd 8:0:0:0: [sdb] 14651280 2048-byte logical blocks: (30.0 GB/27.9 GiB)
[10675.537966] sd 8:0:0:0: [sdb] Assuming drive cache: write through
[10675.537975] sd 8:0:0:0: [sdb] Attached SCSI removable disk

lsusb -v

Bus 001 Device 010: ID 05ac:1209 Apple, Inc. iPod Video
Device Descriptor:

bLength                18
bDescriptorType         1
bcdUSB               2.00
bDeviceClass            0 (Defined at Interface level)
bDeviceSubClass         0 
bDeviceProtocol         0 
bMaxPacketSize0        64
idVendor           0x05ac Apple, Inc.
idProduct          0x1209 iPod Video
bcdDevice            1.00
iManufacturer           1 Rockbox.org
iProduct                2 Rockbox media player
iSerial                 3 300000000000A270015D5EEDF
bNumConfigurations      1
Configuration Descriptor:
  bLength                 9
  bDescriptorType         2
  wTotalLength           57
  bNumInterfaces          2
  bConfigurationValue     1
  iConfiguration          0 
  bmAttributes         0xc0
    Self Powered
  MaxPower              500mA
  Interface Descriptor:
    bLength                 9
    bDescriptorType         4
    bInterfaceNumber        0
    bAlternateSetting       0
    bNumEndpoints           2
    bInterfaceClass         8 Mass Storage
    bInterfaceSubClass      6 SCSI
    bInterfaceProtocol     80 Bulk (Zip)
    iInterface              0 
    Endpoint Descriptor:
      bLength                 7
      bDescriptorType         5
      bEndpointAddress     0x81  EP 1 IN
      bmAttributes            2
        Transfer Type            Bulk
        Synch Type               None
        Usage Type               Data
      wMaxPacketSize     0x0200  1x 512 bytes
      bInterval               0
    Endpoint Descriptor:
      bLength                 7
      bDescriptorType         5
      bEndpointAddress     0x01  EP 1 OUT
      bmAttributes            2
        Transfer Type            Bulk
        Synch Type               None
        Usage Type               Data
      wMaxPacketSize     0x0200  1x 512 bytes
      bInterval               0
  Interface Descriptor:
    bLength                 9
    bDescriptorType         4
    bInterfaceNumber        1
    bAlternateSetting       0
    bNumEndpoints           1
    bInterfaceClass         3 Human Interface Device
    bInterfaceSubClass      1 Boot Interface Subclass
    bInterfaceProtocol      1 Keyboard
    iInterface              0 
      HID Device Descriptor:
        bLength                 9
        bDescriptorType        33
        bcdHID               1.10
        bCountryCode            0 Not supported
        bNumDescriptors         1
        bDescriptorType        34 Report
        wDescriptorLength     133
       Report Descriptors: 
         ** UNAVAILABLE **
    Endpoint Descriptor:
      bLength                 7
      bDescriptorType         5
      bEndpointAddress     0x82  EP 2 IN
      bmAttributes            3
        Transfer Type            Interrupt
        Synch Type               None
        Usage Type               Data
      wMaxPacketSize     0x0008  1x 8 bytes
      bInterval               8

Device Qualifier (for other device speed):

bLength                10
bDescriptorType         6
bcdUSB               2.00
bDeviceClass            0 (Defined at Interface level)
bDeviceSubClass         0 
bDeviceProtocol         0 
bMaxPacketSize0        64
bNumConfigurations      1

Device Status: 0×0000

(Bus Powered)
Admin
Frank Gevaerts commented on 2012-02-10 15:46

There are multiple interfaces on one device, yes. That doesn’t make it a hub, or “like” a hub.

This could well be a bug in the BIOS, but it’s hard to be sure. I’d really like to see this tested with some other non-rockbox device that has both HID and MSC. Unfortunately I’m not aware of any of thoseā€¦

Teun Kloosterman commented on 2012-02-10 20:28

I’m sorry I actually called it a hub, I think I did that because I saw that once in a printer / scanner / copier / cardreader and the Xbox controller. Which actually do have a physical USB hub.
Couldn’t it also be related to the use of USB attached SCSI instead of something less exotic (Don’t know, block device? USB mass storage? USB ata?)
The behaviour is the same on Award and Phoenix, I doubt it’s actually a BIOS bug. Well, anything not living up to expectations could be a bug.

I can’t believe I’m the only one apparently who has this. For me it’s always been like this, when I reboot, I have to unplug my iPod or else my computer just hangs on the BIOS screen.
First time (couple of years ago) I really freaked, thinking my MoBo was broken and immediately flashed the newest BIOS. Took me a while to figure out it’s the iPod who stalls the BIOS (I tested it, I call > 4 hrs indefinitely).

Thomas M. commented on 2012-02-19 11:04

I do not have this issue but I’ve noticed that PCs in general seem to have a hard time booting when there are many USB devices attached.
I’ve had a friend who had 7 external hard disks and he had to unplug half of them to get his machine to boot. My PC also kinda takes its time with all the devices that are attached.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing