Rockbox

Tasklist

FS#12588 - %pt tag not interpreted in seconds in conditional statement

Attached to Project: Rockbox
Opened by dave t (sockbox) - Tuesday, 14 February 2012, 20:00 GMT
Last edited by Frank Gevaerts (fg) - Tuesday, 14 February 2012, 21:30 GMT
Task Type Bugs
Category Themes
Status Closed
Assigned To No-one
Operating System Another
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This statement works in sim build 94177e6, sansa clip+, but no longer works in the current build, 9acd702.

# If less than 10min, less than 1hr, else.
%?if(%pt,<,600)<%Vd(b)|%?if(%pt,<,3600)<%Vd(c)|%Vd(d)>>

If used in a conditional, %pt, total play time, should be interpreted in seconds.

Attached is the sansa clip+ theme. The progress bar size should change dynamically according to song length.
This task depends upon

Closed by  Frank Gevaerts (fg)
Tuesday, 14 February 2012, 21:30 GMT
Reason for closing:  Not a Bug
Comment by dave t (sockbox) - Tuesday, 14 February 2012, 20:45 GMT
Nevermind. Seems to work with another theme. Will have to do more troubleshooting.
Comment by dave t (sockbox) - Tuesday, 14 February 2012, 20:54 GMT
It was an issue with my theme and not the skin engine. Please ignore.

Loading...