Rockbox

  • Status Closed
  • Percent Complete
    0%
  • Task Type Bugs
  • Category User Interface
  • Assigned To
    pamaury
  • Operating System Sansa Fuze+
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by buckminster - 2012-02-20
Last edited by Mendel_munkis - 2020-07-08

FS#12594 - [Fuze+] Unexpected behavior of touchpad when backlight is off

While the backlight is on, all touchpad functionality appears to function normally. I have used a number of daily builds, the current one I’m using is d2f97da-120216. I am running V7 of the bootloader. I reset my settings to default as well.

With “First press turns backlight on” set to “no” and the backlight currently off (keyclick set to “weak” and no repeat):

Menus -
tapping right acts as if I’m holding on the center
tapping left, up, down, or back acts as if I tapped the respective spot twice (goes up/down/back two menu items)

WPS -
tapping right or left acts as if I pressed and held to start to skip through the track (two audible clicks and the Play icon changes to the FFWD or Rewind icon temporarily)
tapping play/pause while music is playing will pause the music and go back one screen
tapping play/pause while music is paused will simply go back one screen

With “First press turns backlight on” set to yes and the backlight currently off (keyclick set to weak and no repeat):

Menus -
tapping right acts as expected (turns backlight on)
tapping left, up, down, or back acts as if I tapped the respective spot once (goes up/down/back one menu item)

WPS -
tapping right or left acts as if I pressed and held to start to skip through the track (one audible click and the Play icon changes to the FFWD or Rewind icon temporarily)
tapping play/pause while music is playing will pause the music and go back one screen
tapping play/pause while music is paused will simply go back one screen

Closed by  Mendel_munkis
2020-07-08 07:49
Reason for closing:  Out of Date
Additional comments about closing:  

Filed pre touchpad driver rewrite

I confirm this: the touchpad is definitly doing strange things while backlight is off. Whe should test this on other target to know if this is fuze+ specific

I can confirm this on my device. It doesn't seem to be fuze+ specific but needs some investigation.

I have fuze v2 (latest official build and several versions prior) and a new fuze+ (latest daily), and confirm that this is an issue with the fuze+ which i've never observed in the fuze v2.

Using the current development build as of this writing, I cannot reproduce this behavior. The fuze+'s touchpad drive gained a deadzone setting for it's virtual button since then. And seems to fix many of the touchpads down falls.
Please, can any of you confirm this behavior still exists or not with a current development build?

I can attempt to validate this when I get a chance - thanks for the update, if this is fixed it'll definitely make the fuze+ a more usable device when Rockboxed!

I am still exhibiting this behavior with the latest dev builds (currently on 5dab768-141215). I'm using default settings for Touchpad Sensitivity and Dead Zone. What settings are you using smartben?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing