Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Operating System/Drivers
  • Assigned To No-one
  • Operating System Sansa AMSv2
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: Rockbox
Opened by Wolfgang Dilg - 2012-02-27
Last edited by MichaelGiacomelli - 2016-08-28

FS#12601 - somethings wrong with usb on clip+

With the newest release (9f48f5f) there is something wrong with the usb connection of my clip+. It looks like the modification of the main menu triggers some memory corruption when connecting to usb.

After several connects and disconnects (without securely dismouting the clip+ on windows 7 64bit) there appears some pixel garbage in the yellow line on top left in the usb connection screen. When this happens the clip+ is not necessarily mounted in a right way (sometines only the card slot appears). After disconnecting the player the main menu is shifted about a line to the top ( the second line slips into the yellow part of the display). After connecting the player again it usually freezes in usb screen and has to to shut down by pressing the power button a long time.

Closed by  MichaelGiacomelli
2016-08-28 20:13
Reason for closing:  Out of Date
Additional comments about closing:  

Closing bug reports for the old USB stack now that we have the new one committed and stable. Most likely these problems are fixed now.

Bertrik Sikken commented on 2012-02-27 19:48

Hm, I’ve seen pixel garbage too on the top left of the screen. The USB transfers themselves that I did before that seemed to be OK, so my feeling is that it’s not USB itself that is malfunctioning.
Mine’s a sansa clip zip running a custom theme, so I was afraid of posting bugs (it’s still unstable).

Wolfgang Dilg commented on 2012-02-28 10:36

When the DAP is successfully mounted the transfers from an to the drive seem to be ok. I haven’t seen broken transfers for a while.

Tomas commented on 2012-03-09 23:51

At 80 percent I didn’t succeed when I was trying to use usb with cd5ee6f build on two computers. It gets stuck and only long press of power off worked so I had to install official 3.10 release and use OF for usb. :-(

Wolfgang Dilg commented on 2012-06-25 11:01

After a long time I’ve recently encountered this issue with build d245997 again.

MichaelGiacomelli commented on 2012-07-13 16:16

Can you zip and link your entire .rockbox folder? MIght be interesting if I can reproduce it on mine.

Wolfgang Dilg commented on 2012-07-18 20:17

This is a slightly newer version. But I’ve encountered the crash with this version lately.

Wolfgang Dilg commented on 2012-09-13 19:10

With 4ebc7df I’ve encountered another crash when starting clip+ with usb inserted under windows 7 64bit. After inserting usb cable the clip+ booted, switched immediatley to the usb screen and freezed. No mass storage device appeared. The player had to be resetted the usual way.

Lars Täuber commented on 2013-05-13 21:12

Hi!

This seems to be a dupliacte of  FS#12461 

Lars Täuber commented on 2013-05-13 21:23

Please set the priority ti high, because it makes the sansa clip+ nearly unusable without microSD

The problem still exists with RockBox 3.13 and bootloader 4.0.

Connecting the clip+ to a linux box sometimes a device shows up in /proc/partitions but the partition table can’t be read:

[ 9158.877900] usb 2-1.2: new high-speed USB device number 55 using ehci_hcd
[ 9159.065369] scsi37 : usb-storage 2-1.2:1.0
[ 9160.061549] scsi 37:0:0:0: Direct-Access Rockbox Internal Storage 0.00 PQ: 0 ANSI: 4
[ 9160.062039] scsi 37:0:0:1: Direct-Access Rockbox SD Card Slot 0.00 PQ: 0 ANSI: 4
[ 9160.062848] sd 37:0:0:0: Attached scsi generic sg4 type 0
[ 9160.063136] sd 37:0:0:1: Attached scsi generic sg5 type 0
[ 9160.065973] sd 37:0:0:0: [sdd] 7683072 512-byte logical blocks: (3.93 GB/3.66 GiB)
[ 9160.067083] sd 37:0:0:0: [sdd] Write Protect is off
[ 9160.067087] sd 37:0:0:0: [sdd] Mode Sense: 0b 00 00 08
[ 9160.068200] sd 37:0:0:0: [sdd] No Caching mode page present
[ 9160.068205] sd 37:0:0:0: [sdd] Assuming drive cache: write through
[ 9160.068884] sd 37:0:0:1: [sde] Attached SCSI removable disk
[ 9160.075069] sd 37:0:0:0: [sdd] No Caching mode page present
[ 9160.075073] sd 37:0:0:0: [sdd] Assuming drive cache: write through
[ 9160.077598] sdd:
[ 9160.080311] sd 37:0:0:0: [sdd] No Caching mode page present
[ 9160.080315] sd 37:0:0:0: [sdd] Assuming drive cache: write through
[ 9160.080319] sd 37:0:0:0: [sdd] Attached SCSI removable disk
[ 9191.166606] usb 2-1.2: reset high-speed USB device number 55 using ehci_hcd
[ 9206.223993] usb 2-1.2: device descriptor read/64, error -110
[ 9221.385163] usb 2-1.2: device descriptor read/64, error -110
[ 9221.564981] usb 2-1.2: reset high-speed USB device number 55 using ehci_hcd
[ 9236.622366] usb 2-1.2: device descriptor read/64, error -110
[ 9251.783732] usb 2-1.2: device descriptor read/64, error -110
[ 9251.959537] usb 2-1.2: reset high-speed USB device number 55 using ehci_hcd
[ 9257.362166] usb 2-1.2: device not accepting address 55, error -71
[ 9257.434180] usb 2-1.2: reset high-speed USB device number 55 using ehci_hcd
[ 9262.840816] usb 2-1.2: device not accepting address 55, error -71
[ 9262.841224] sd 37:0:0:0: Device offlined - not ready after error recovery
[ 9262.841288] usb 2-1.2: USB disconnect, device number 55
[ 9262.841411] sdd: detected capacity change from 3933732864 to 0
[ 9262.920912] usb 2-1.2: new high-speed USB device number 56 using ehci_hcd
[ 9277.978377] usb 2-1.2: device descriptor read/64, error -110
[ 9293.139678] usb 2-1.2: device descriptor read/64, error -110
[ 9293.315507] usb 2-1.2: new high-speed USB device number 57 using ehci_hcd
[ 9308.372915] usb 2-1.2: device descriptor read/64, error -110
[ 9323.534087] usb 2-1.2: device descriptor read/64, error -110
[ 9323.709901] usb 2-1.2: new high-speed USB device number 58 using ehci_hcd
[ 9329.116558] usb 2-1.2: device not accepting address 58, error -71
[ 9329.188555] usb 2-1.2: new high-speed USB device number 59 using ehci_hcd
[ 9334.595242] usb 2-1.2: device not accepting address 59, error -71
[ 9334.595398] hub 2-1:1.0: unable to enumerate USB device on port 2

most of the tries I have to hard reset the clip+ by holding down the power switch for more than 10sec.

I’d like to donate for a bug fix.

Regards
Lars

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing