Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System Sansa AMSv2
  • Severity Low
  • Priority Very Low
  • Reported Version Release 3.10
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by rudo - 2012-03-05
Last edited by MikeS - 2012-11-30

FS#12607 - Pausing/fast-forwarding/skipping Ogg Vorbis files with EQ on produces clicking sounds on Clip+.

Pausing/fast-forwarding/skipping Ogg Vorbis files with EQ on produces clicking sounds on Clip+.

Please see attached recording oggEQon.flac, in which you can hear the clicks that happen when: starting playback, pausing, unpausing, starting fast-forward, releasing the button, and skipping a track – in this order. I had a playlist with Vorbis files with silence (also attached).

Any non-zero equalizer setting does this. Precut and Replaygain don’t seem to change anything. Turning EQ off or setting it to all zeroes makes the clicking sounds go away (see oggEQoff.flac).

Note that this is specific to OGG Vorbis files. The FLAC and MP3 ones I tried worked fine.

This bug first appeared in the 3.10 release, and is still present it today’s daily build (d18a5ca).

Please let me know if I should provide any more info. I have built Rockbox in the past (even though it was a long time ago), so I should be able to test patches :)

Thanks.

Closed by  MikeS
2012-11-30 23:40
Reason for closing:  Fixed
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

Reported by filer fixed in 3.12.

rudo commented on 2012-03-05 02:24

Forgot to mention that the 3.9.1 release is not affected.

Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557

http://svn.rockbox.org/viewvc.cgi?view=rev;revision=30097

Feel like trying r30096 to see if the PCM mixer rework introduced this problem?

MikeS commented on 2012-03-05 10:15

I’ve noticed m4a also has this issue (I had commented somewhere about it). wav, wv, aiff, mp3, spc, vgm don’t. Tone controls also seem to affect this. When it came about, I don’t know. I’d expect the mixer to be non-selective about the format.

It’s also not unique to AMSv2. I tried on PP5024 as well with the same tracks (of my own).

rudo commented on 2012-03-06 00:30

FWIW, I tried r30096, and it had issues with clicking noise even with EQ off. So r30097 does not seem to be the culprit here.

I couldn’t reproduce the problem with the emulator, so I guess I’ll have to bisect. There are 875 revisions between v3.9.1-final and v3.10-final, so if it’s a single commit that caused this, it will take me 10 tries.

Or do you guys suspect any other revisions/commits I could try? :)

Thanks!

rudo commented on 2012-04-02 00:14

I haven’t got around to bisecting through the revisions, but can confirm this bug is still present in 3.11.

rudo commented on 2012-04-02 00:26

Further testing shows that 3.9.1 has this problem too, but only when fast-forwarding (and rewinding), *not* on pause, *not* on track change.

MikeS commented on 2012-04-10 23:41

Maybe, just maybe, DSP_FLUSH isn’t wiping the filter history. That would apply to EQ, tone and crossfeed if so. (hint)

rudo commented on 2012-11-26 15:22

This seems to have been fixed in 3.12.

MikeS, can you confirm this? :)

Thanks!

MikeS commented on 2012-11-30 23:39

I seem to recall that I did specifically attack the issue but don’t remember _exactly_ which change I made. IIRC there was something with zeroing filter history as well as codecs possibly creating an extra frame of audio after they were told to stop (now they’re barred from getting frames processed until they ack the stop). The problem went away for me where I could produce it. Since you report it gone and I concur, I’ll close the task. Reopen if necessary.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing