Rockbox

Tasklist

FS#12625 - Sleep Timer Context Menu / Failed Cancellation

Attached to Project: Rockbox
Opened by William Stark (qhorin) - Tuesday, 27 March 2012, 06:35 GMT
Last edited by Nick Peskett (nickp) - Thursday, 29 March 2012, 07:09 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System Sansa AMSv2
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Version: 215ac63-120326
Player: Sansa Clip+ 8GB

The sleep timer menu (Settings > General Settings > Startup/Shutdown > Sleep Timer) does not have a context menu. This might be expected behavior, but breaks consistency, given that almost all other menus have context menus. The possibility to add a sleep timer via quickscreen or shortcut would be very useful.

Also when entering the sleep timer menu and exiting it with the cancel action (power button on clip+), the sleep timer gets set anyway.

This task depends upon

Closed by  Nick Peskett (nickp)
Thursday, 29 March 2012, 07:09 GMT
Reason for closing:  Fixed
Additional comments about closing:  The first part can be achieved with shortcuts, the second part is fixed with commit 10d8717.
Comment by Marek Salaba (salaba) - Tuesday, 27 March 2012, 22:30 GMT
I certify that when entering the sleep timer menu and exiting it with the cancel action (left click of wheel on Fuze), the sleep timer gets set anyway. Normaly would be show popup Canceled and nothing set.

I think that adding to the quickscreen is not good idea because how it
works - adjustment would have to do only in the direction of adding up minutes and off would be at the end all of values.
Adding to tho shortcuts is now possible by the direct set (it is desribet in manual in section 5.14 by the type "time")
but interactively adjustable sleep timer from shortcut I think it's a good idea.

Thus as I proposed to add to shortcuts a change languages​​, but not to quickscreen.
Comment by menachem shapiro (menachem) - Wednesday, 28 March 2012, 16:51 GMT
Here's an answer to the first part of the question:
http://www.rockbox.org/tracker/task/12562

Comment by menachem shapiro (menachem) - Wednesday, 28 March 2012, 16:56 GMT
I've attached my shortcuts.txt, so you can see how it is done. Here's the relevent documentation:
http://download.rockbox.org/daily/manual/rockbox-sansaclipplus/rockbox-buildch5.html#x8-1010005.14

Loading...