Rockbox

Tasklist

FS#12648 - When a track is manually skipped back to its beginning, a “click” occurs before it replays

Attached to Project: Rockbox
Opened by Terry Layton (Terry The Great) - Thursday, 19 April 2012, 20:25 GMT
Last edited by Frank Gevaerts (fg) - Thursday, 19 April 2012, 20:50 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System Sansa AMSv2
Severity Low
Priority Normal
Reported Version Release 3.11
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hardware device(s): Sansa® Fuze™ v2 (this exact same problem has also been heard on the Fuze+)
Original manufacturer’s firmware version: 02.03.33
Rockbox version: 3.11.2 (the current release), bc41926 and the current build

The problem described in the title is the same as that reported in  FS#12393 . Prematurely, Alex Parker (BigBambi) determined  FS#12393  fixed as reported in this message:

From: Rockbox(tracker@rockbox.org)
Sent: April-13-12 12:13:14 PM
To: terrythegreat-1@hotmail.com

The following task is now closed:

 FS#12393  - Annoying "click" before track restarts
User who did this - Alex Parker (BigBambi)

Reason for closing: Fixed
Additional comments about closing: Fixed in current build (bc41926, 13 April 2012)

More information can be found at the following URL:
http://www.rockbox.org/tracker/task/12393
********************************************

This task was closed without giving me an opportunity to provide my feedback on whether the repair he did had been successful, which in this case it was not. This is an example of how MichaelGiacomelli (saratoga) did this properly with another bug fix:

 FS#12633  - Loud “clunk” when the user manually skips back to the start of a WMA file
User who did this - MichaelGiacomelli (saratoga)

----------
Should be fixed in bc41926. Confirm and I'll close it.
----------

More information can be found at the following URL:
http://www.rockbox.org/tracker/task/12633#comment42559
********************************************

I was given the chance to review the changes and comment. As a result this bug is now fixed (the loud “clunk” no longer occurs) and this task is properly closed.

As indicated above,  FS#12393  was not successfully fixed and this task is being submitted to replace it. At least some tests were conducted on the MP3 files I included and the problem confirmed (as reported in this earlier message to me):

From: Rockbox(tracker@rockbox.org)
Sent: April-13-12 12:06:49 PM
To: terrythegreat-1@hotmail.com

 FS#12393  - Annoying "click" before track restarts
User who did this - Alex Parker (BigBambi)

----------
Curiously I can reproduce this on Fuze v2, but only with the track attached to this bug report and not with any others that I tried. I don't have any wma to try. I haven't tried on any other targets.
********************************************

Firstly, I have conducted tests using bc41926, release 3.11.2 and the current build on this track and many others downloaded randomly from the internet, including MP3s and WMAs. The results are always the same as described in  FS#12393 . The attached tracks were produced on a friend’s computer using Windows Media Player 12 to rip them from a CD and then transferred to the player. However, I find that these tracks behave exactly the same as those produced on my computer and additionally that of the local university’s machines after a full virus scan. As reported in  FS#12393 , when the user skips back to the start of a track after a few seconds of play, there is an annoying “click” before the music restarts. Also this “click” now occurs whenever the user skips forward a track or back to the previous one. Admittedly, what Alex Parker (BigBambi) may have missed is that occasionally when the WPS playback is activated immediately after powering up the player the “click” may have a much lower volume until after this function is activated a few times. That is why a number of tests lasting a few minutes with a few tracks should always be run to determine whether this bug still occurs after a fix is applied. There may also have been some confusion because BigBambi and saratoga were working on fixing similar problems and their repairs were both included in daily release bc41926.

Secondly, the same problem also occurs on the Sansa Fuze+. It is true that this is classified as an unstable port but since the “click” occurs in the same manner and has exactly the same sound as on the Fuze v2, I can’t help but conclude that this is a problem with the firmware and not with the player or the tracks used.

I would be happy to review your new changes designed to fix this problem and provide constructive feedback. Your goal should be to make the Rockbox firmware as silent as the Sansa firmware during these transitions using the files attached to this report.
This task depends upon

Closed by  Frank Gevaerts (fg)
Thursday, 19 April 2012, 20:50 GMT
Reason for closing:  Invalid
Additional comments about closing:  This is a combination of a rant that does not belong on the tracker and information about another bug.
If you think a bug has been closed prematurely, you can tell us about this in an adult way, and it will be reopened.
Comment by Alex Parker (BigBambi) - Thursday, 19 April 2012, 20:47 GMT
You seem confused on a number of levels.

A) I didn't fix 12393, saratoga did. You would have seen this if you checked the commit I referenced.

B) I checked with the file you attached, and heard the noise. I then checked with a build after the fix was committed, and didn't hear the noise. Therefore the noise is fixed.

C) I have rechecked all the files you have attached. They all work. Try again with a current (i.e. today) build.

C) You really really need to work on your attitude. "I would be happy to review your new changes designed to fix this problem and provide constructive feedback. Your goal should be to make the Rockbox firmware as silent as the Sansa firmware during these transitions using the files attached to this report." Thanks very much.

Loading...