FS#1265 - sleep timer leaves player on

Attached to Project: Rockbox
Opened by Anonymous Submitter - Thursday, 24 April 2003, 00:12 GMT
Last edited by Daniel Stenberg (bagder) - Friday, 05 December 2003, 09:37 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No


when I have the sleep timer go with it plugged in, (as I
would assume most people have their players when they
use sleep timer), it doesn't pause or anything, it just
stops in midsong. This doesn't let the player shutdown
automatically and leave it on all night (in my case). If it
paused or automatically powered down it would be great.
This task depends upon

Closed by  Daniel Stenberg (bagder)
Friday, 05 December 2003, 09:37 GMT
Reason for closing:  Rejected
Comment by Anonymous Submitter - Friday, 28 November 2003, 15:39 GMT

Yeah, I have noticed this too, when hooked to the charger,
the player doesn't shutdown when the sleep timer is
engaged, but I think this is intentional because it lets the
player charge with less drain on the unit and the backlight
off, I know when I first got my player with the standard
firmware, that the player got very very hot and burned my
hand when I touched it in the morning with it running all night.
Comment by Björn Stenberg (zagor) - Friday, 28 November 2003, 17:03 GMT

This is not a bug, it's deliberate behaviour.

You can't shut off the device while plugged in (except for very old 6000
players). Note how the screen says "charging" when you are charging
it? That means it's turned on.